GTY's math problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2099    Accepted Submission(s): 774

Problem Description
GTY
is a GodBull who will get an Au in NOI . To have more time to learn
algorithm knowledge, he never does his math homework. His math teacher
is very unhappy for that, but she can't do anything because GTY can
always get a good mark in math exams. One day, the math teacher asked
GTY to answer a question. There are four numbers on the blackboard - a,b,c,d. The math teacher wants GTY to compare ab with cd.
Because GTY never does his homework, he can't figure out this problem!
If GTY can't answer this question correctly, he will have to do his
homework. So help him!
 
Input
Multi test cases (about 5000). Every case contains four integers a,b,c,d(1≤a,b,c,d≤1000)separated by spaces. Please process to the end of file.
 
Output
For each case , if ab>cd , print '>'. if ab<cd , print '<'. if ab=cd , print '='.
 
Sample Input
2 1 1 2
2 4 4 2
10 10 9 11
 
Sample Output
>
=
<
 
题意:判断 a^b 和 c^d 的大小关系.
题解:同时平方肯定会炸,所以取对数之后进行比较.
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <math.h>
using namespace std;
const double eps = 1e-; int main()
{
int a,b,c,d;
while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF){
double n = b*log(a)-d*log(c);
if(fabs(n)<eps) printf("=\n");
else if(n<) printf("<\n");
else printf(">\n");
}
return ;
}

最新文章

  1. Unity3d外包(北京)公司(长年承接U3D外包)
  2. ELK日志解决方案安装配置与使用
  3. Delphi的面向对象编程基础笔记
  4. C++中 容易忽视的const 修饰符
  5. basic use of sidekiq
  6. Android ListView 第一次设置Adapter时候getView调用多次
  7. POJ 2455 - Secret Milking Machine
  8. java开发规范总结_代码编码规范
  9. JavaScript自我学习之解析与执行
  10. MongoDB Error
  11. Threejs 的场景查看 - 几个交互事件库助你方便查看场景
  12. flex 用footerdatagrid做列的汇总合计
  13. Intent对象详解——使用Intent启动系统组件
  14. Python基础【day03】:字典(一)
  15. 元素位置pageX,pageY,clientX,clientY,scrollX,scrollY,screenX,screenY,offsetX,offsetY
  16. [lisp] scheme学习2
  17. c# 读取excel数据的两种方法
  18. Quartus调用MOdelsim仿真过程
  19. python HTMLTestRunner.py
  20. 越来越不习惯客户端了,于是卸载了xmapp,重新配置了php+apache+mysql

热门文章

  1. PM所该学习的
  2. PHP与webserver【简书看到的】
  3. BZOJ4105 THUSC2015平方运算(线段树)
  4. BZOJ4567 SCOI2016背单词(trie+贪心)
  5. C#IList 取区间数据
  6. [洛谷P2839][国家集训队]middle
  7. BZOJ 3319 黑白树 并查集+线段树
  8. BZOJ1798 维护序列seq
  9. jquery的ajax实现方式
  10. mmall项目之问题一(mavenplugin问题)