How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1035    Accepted Submission(s): 356

Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you."
or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.



Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.



You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 
Input
There are several test cases.



For each test case:



The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)



Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.



The input ends with N = 0 and M = 0.



It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 
Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 
Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
 
Sample Output
50
Inf
 
Source

/*这道题并不麻烦,刚开始我还想用邻接表搜索,记录深度,同时记录分支,但是感觉太繁琐
,其实可以列举每一个可以说服的人设为x,那么1--x和x--j都可以设置为INF,然后算一下最短路,
但是需要再开一个数组,因为一次的floyd会破坏数组里的数据,记录下来最短路中的最长路,判断*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f
int map[1010][1010],dp[1010][1010],m,n;
int purr(int x)
{
int i,j,k;
memset(dp,0,sizeof(dp));
for(i=1;i<=m;i++)
for(j=1;j<=m;j++)
{
if(i==x||j==x) dp[i][j]=INF;
else dp[i][j]=map[i][j];
}
for(k=1;k<=m;k++)
for(i=1;i<=m;i++)
for(j=1;j<=m;j++)
{
if(i==j) continue;
else dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]);
}
return dp[1][m];
}
int main()
{
while(scanf("%d%d",&m,&n),m|n)
{
memset(map,0,sizeof(map));
int i,j,k,a,b,c;
for(i=1;i<=m;i++)
for(j=1;j<=m;j++)
{
if(i==j) map[i][j]=0;
else map[j][i]=map[i][j]=INF;
}
for(i=0;i<n;i++)
{
scanf("%d%d%d",&a,&b,&c);
if(c<map[a][b])
map[a][b]=map[b][a]=c;
}
int ans=0;
for(i=2;i<m;i++)
{
ans=max(ans,purr(i));//列举每一个可以说服的人
}
if(ans==INF) printf("Inf\n");
else printf("%d\n",ans);
}
return 0;
}

最新文章

  1. css font-weight原理
  2. MySQL执行计划中key_len详解
  3. Swift语言实战晋级-第9章 游戏实战-跑酷熊猫-3 显示一个动态的熊猫
  4. node.js 学习书籍推荐
  5. SQL SERVER 生成MYSQL建表脚本
  6. F. Igor and Interesting Numbers
  7. eclipse 注释模板设置
  8. 复杂事件处理引擎—Esper入门
  9. 协同过滤(CF)算法
  10. [科普]DNS相关的攻击介绍
  11. ecshop后台管理显示扩展分类
  12. 为Play初学者准备的Scala基础知识
  13. Cause: net.sf.cglib.beans.BulkBeanException; nested exception is com.ibatis.common.jdbc.exception.NestedSQLException:
  14. .net core consul 服务配置 服务发现 服务健康检测 服务变更加载
  15. 任务超时退出的方法 C#
  16. Aws云服务EMR使用
  17. 大神你好,可以帮我P张图吗?
  18. Android-Java-等待唤醒机制原理
  19. 安装使用Entity Framework Power Tool Bate4 (Code First)从已建好的数据自动生成项目中的对应Model(新手贴,望各位大侠给予指点)
  20. 【转】Android7.0适配心得

热门文章

  1. redis-linux
  2. 在 ef 中执行 DbContext.Table.AddRange(Enitites).ToList() 会发生什么
  3. HDU_1729_sg函数(dfs)
  4. Luogu P1365 WJMZBMR打osu! / Easy
  5. 【转】在VMware中为Linux系统安装VM-Tools的详解教程
  6. python-selenium,关于页面滑动
  7. 【剑指Offer】39、平衡二叉树
  8. USACO 4.1 Fence Loops
  9. 关于js开发中保留小数位计算函数(以向上取整或向下取整的方式保留小数)
  10. 继续聊WPF——Expander控件(1)