Electrical Outlets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9597   Accepted: 7186

Description

Roy has just moved into a new apartment. Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy's
apartment has only one single wall outlet, so Roy can only power one of his electrical appliances at a time. 

Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time.
The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now. 

Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered
itself to be of any use.

Input

Input will start with a single integer 1 <= N <= 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 <= K <= 10, indicating the number of power strips in the test case.
Then follow, on the same line, K integers separated by single spaces, O1 O2 . . . OK, where 2 <= Oi <= 10, indicating the number of outlets in each power strip.

Output

Output one line per test case, with the maximum number of appliances that can be powered.

Sample Input

3
3 2 3 4
10 4 4 4 4 4 4 4 4 4 4
4 10 10 10 10

Sample Output

7
31
37

Source

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include<stdio.h>
int main()
{
int t, a, sum, n, i;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
sum = 1 - n;
for(i=0; i<n; i++)
{
scanf("%d",&a);
sum += a;
}
printf("%d\n",sum);
}
}

最新文章

  1. Android Material Design之 NavigationView侧滑界面自定义 随笔
  2. 第一章 企业项目开发--maven+springmvc+spring+mybatis+velocity整合
  3. Apache配置代理服务器的方法(2)
  4. windows端加密程序,lua代码,ZeroBrane调试
  5. JS 对象(Object)和字符串(String)互转
  6. InnoDB存储引擎
  7. 安装VMware Sphere ESXi 5.5
  8. postgis 中的距离计算
  9. 非确定性计算引擎转化为C#版本并重构
  10. Python_文本操作
  11. Mycat的读写分离
  12. [转]php,使用Slim和Medoo搭建简单restful服务
  13. sql 用户相关命令
  14. npx小工具
  15. The Monocycle(bfs)
  16. Forth嵌套定义的执行过程图示
  17. Centos6.5使用ELK(Elasticsearch + Logstash + Kibana) 搭建日志集中分析平台实践
  18. squid介绍和作用
  19. ARM linux内核启动时几个关键地址【转】
  20. Source not found :Edit Source Lookup Path 解决方案

热门文章

  1. 我能考虑到的数组(老)方法就这些了(es5)
  2. 【Kafka问题解决】Connection to xxx could not be established. Broker may not be available.
  3. 拥抱变革(More Fearless Change)
  4. 60. Spring Boot写后感【从零开始学Spring Boot】
  5. POJ-1679 The Unique MST,次小生成树模板题
  6. [luoguP1410] 子序列(DP)
  7. noip模拟赛 星空
  8. POJ 3415 (后缀自动机)
  9. Linux下汇编语言学习笔记3 ---
  10. Java Web 总结