问题描述
  给定一个整数数列,数列中连续相同的最长整数序列算成一段,问数列中共有多少段?
输入格式
  输入的第一行包含一个整数n,表示数列中整数的个数。
  第二行包含n个整数a1, a2, …, an,表示给定的数列,相邻的整数之间用一个空格分隔。
输出格式
  输出一个整数,表示给定的数列有多个段。
样例输入
8
8 8 8 0 12 12 8 0
样例输出
5
样例说明
  8 8 8是第一段,0是第二段,12 12是第三段,倒数第二个整数8是第四段,最后一个0是第五段。
评测用例规模与约定
  1 ≤ n ≤ 1000,0 ≤ ai ≤ 1000。
析:扫一遍即可。
代码如下:
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <string>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <cstring>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <map>
#include <cctype>
#include <cmath>
#include <stack>
#define freopenr freopen("in.txt", "r", stdin)
#define freopenw freopen("out.txt", "w", stdout)
using namespace std; typedef long long LL;
typedef pair<int, int> P;
const int INF = 0x3f3f3f3f;
const double inf = 0x3f3f3f3f3f3f;
const LL LNF = 0x3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int maxn = 1e4 + 5;
const int mod = 1e9 + 7;
const int dr[] = {-1, 0, 1, 0};
const int dc[] = {0, 1, 0, -1};
const char *Hex[] = {"0000", "0001", "0010", "0011", "0100", "0101", "0110", "0111", "1000", "1001", "1010", "1011", "1100", "1101", "1110", "1111"};
int n, m;
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
inline int Min(int a, int b){ return a < b ? a : b; }
inline int Max(int a, int b){ return a > b ? a : b; }
inline LL Min(LL a, LL b){ return a < b ? a : b; }
inline LL Max(LL a, LL b){ return a > b ? a : b; }
inline bool is_in(int r, int c){
return r >= 0 && r < n && c >= 0 && c < m;
} int main(){
while(scanf("%d", &n) == 1){
int ans = 1, x, y;
scanf("%d", &x);
for(int i = 1; i < n; ++i){
scanf("%d", &y);
if(y != x) ++ans;
x = y;
}
printf("%d\n", ans);
}
return 0;
}

最新文章

  1. 在Activity之间传递参数(一)
  2. 00 MySQL
  3. 框架Hibernate笔记系列 基础Session
  4. 【转】XPath 示例
  5. iOS10 升级兼容必备参考
  6. 如何在wp8 中调试cocos2dx c++ 代码
  7. oracle定时任务
  8. winform的comboBox使鼠标滑轮修改值失效
  9. 《Head First 设计模式》ch.2 观察者(Observer)模式
  10. httpClient无证书访问
  11. Nexus搭建Maven服务器
  12. jquery 实现横向滑动自动切换源码(同时显示多张图片)
  13. OPENSSL库的使用-DES篇
  14. MyBatis 源码分析——SqlSession接口和Executor类
  15. ABP core学习之二 IIS部署.NET CORE
  16. Python 面向对象的补充
  17. &lt;转&gt;pandas学习
  18. springboot 知识点
  19. bzoj3143 游走
  20. 关于PHP 时区错误的问题

热门文章

  1. C#.NET开源项目、机器学习、Power BI (转载)
  2. 生产追溯系统-Wifi+传感器,实现计数器以及监控机器是否停止
  3. HSSFWorkbook
  4. ANALYSIS AND EXPLOITATION OF A LINUX KERNEL VULNERABILITY (CVE-2016-0728)
  5. dsoframer注冊说明及在VC2010使用
  6. Android 向右滑动销毁(finish)Activity, 随着手势的滑动而滑动的效果
  7. MVC入门——列表页
  8. UML类图关系表示方法
  9. php 面向对象的三大要素(封装、继承、多态)以及重写(override)和重载(overload)的举例说明
  10. Netty 100万级高并发服务器配置