Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34347 Accepted Submission(s): 15188

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.



Note: the number of first circle should always be 1.




Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.



You are to write a program that completes above process.



Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4 Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
Source
Recommend
JGShining | We have carefully selected several similar problems for you:10101312
1072

pid=1242">
1242

pid=1175">
1175


<pre name="code" class="html">#include<stdio.h>
#include<string.h>
bool prim[44],visit[22];
int b[22];
int n;
void f(){
prim[2]=prim[3]=prim[5]=prim[7]=prim[11]=prim[13]=prim[17]=prim[19]=1;
prim[23]=prim[29]=prim[31]=prim[37]=prim[41]=1;
}
void dfs(int op){
if(op==n){
if(!prim[b[op-1]+b[0]]) return;
printf("%d",b[0]);
for(int i=1;i<n;++i)
printf(" %d",b[i]);
printf("\n");
return;
}
for(int i=2;i<=n;++i){
if(!visit[i]){
if(prim[b[op-1]+i]){
b[op]=i;visit[i]=1;dfs(op+1);
}
visit[i]=0;
}
}
}
int main(){
f();
int ncas=0;
while(~scanf("%d",&n)){
printf("Case %d:\n",++ncas);
memset(visit,0,sizeof(visit));
b[0]=1;dfs(1);
printf("\n");
}
return 0;
}


最新文章

  1. css 固定HTML表格的宽度
  2. ***CodeIgniter集成微信支付(转)
  3. Windows10 会不会成为微软的新起点?
  4. 常用 Java 静态代码分析工具的分析与比较
  5. c++之map
  6. 组合数(codevs 1631)
  7. java的socket 编程
  8. insert into select 堵塞update
  9. 网络编程(学习整理)---2--(Udp)实现简单的控制台聊天室
  10. 基于visual Studio2013解决面试题之0909移动星号
  11. RegExp(正则表达式)常用知识点小结
  12. Spark 贝叶斯分类算法
  13. Oracle结合Mybatis实现取表中前10条数据
  14. python多进程之间的通信:消息队列Queue
  15. Visual Studio 2013创建自定义多项目模版
  16. 学生管理系统_排序后通过name删除列表里的字典
  17. 6.JAVA-链表实例
  18. Jmeter设置代理,抓包之app请求
  19. 弹性盒子模型属性之flex-shrink
  20. [Linux]-Linux常用命令之文件解压

热门文章

  1. centos7 配置redis
  2. Mysql-in查询问题
  3. 安装Git和图形化软件[SouceTree跳过首次登陆]
  4. 14.hash_set(已过时,被unorded_set替代)
  5. 【转】Android ClearEditText:输入用户名、密码错误时整体删除及输入为空时候晃动提示
  6. 关于linq使用建议
  7. DedeCMS让channelartlist支持currentstyle属性
  8. NodeJS学习笔记 (29)二进制解码-string_decoder(ok)
  9. LNMP安装部署开源IP管理工具phpipam
  10. 钩子(hooks)—webhook-使用钩子自动触发部署