GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7357    Accepted Submission(s): 2698

Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number
pairs.

Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.



Yoiu can assume that a = c = 1 in all test cases.
 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.

Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 
Output
For each test case, print the number of choices. Use the format in the example.
 
Sample Input
2
1 3 1 5 1
1 11014 1 14409 9
 
Sample Output
Case 1: 9
Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 
Source


题目大意:求出[a,b]和[c,d]区间里面gcd(x,y)=k的数的对数。

思路:既然是求gcd为k的数的对数,最好还是先将b和d都除以k,这样问题就转化为[1,n]和[1,m]区间里面gcd(x,y)为1 的数的对数。由于题目里已经说明a和c 能够觉得是1,这样就更简单了。

对于一个[1,n]的区间。我们能够用欧拉函数算出总对数。

那么问题就能够分解成2个:
1、在[1,n]上用欧拉函数算出总对数。

2、在[n+1,m]上。计算在[1,n]里面的总对数,能够用容斥原理。
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<vector>
#define min(a,b) a<b?a:b
#define max(a,b) a>b? a:b
#define Max 100005
#define LL __int64
using namespace std;
LL sum[Max],tot;
int p[Max][20];
int num[Max];
void init()
{
sum[1]=1;
for(int i=2;i<Max;i++)
sum[i]=i;
for(int i=2;i<Max;i++)
if(sum[i]==i)
for(int j=i;j<Max;j+=i)
sum[j]=sum[j]/i*(i-1); }
void init2()
{
LL x,k,i,j;
for( i=1;i<=Max;i++)
{
x=i;k=0;
for(j=2;j<=sqrt(i);j++)
{
if(x%j==0){
while(x%j==0)x=x/j;
// p[i].push_back(j);
p[i][num[i]++]=j;
}
}
if(x>1)p[i][num[i]++]=x;
}
}
LL dfs(int n,int b,int x,int k)
{
LL ans=0;
for(int i=x;i<k;i++)
{
ans+=b/p[n][i]-dfs(n,b/p[n][i],i+1,k);
}
return ans;
}
int main()
{
LL T,a,b,c,d,k;
int i,j,t;
init();
init2();
// printf("%I64d %I64d\n",sum[2],sum[3]);
scanf("%I64d",&T);
t=0;
while(T--)
{
tot=0;
t++;
scanf("%I64d%I64d%I64d%I64d%I64d",&a,&b,&c,&d,&k);
printf("Case %d: ",t);
if(k==0){printf("0\n");continue;}
b=b/k;
d=d/k;
int m;
m=min(b,d);
d=max(b,d);
b=m;
for(i=1;i<=b;i++)
tot=tot+sum[i];
for(i=b+1;i<=d;i++)
{
// printf("%d\n",p[i].size());
tot+=b-dfs(i,b,0,num[i]);
}
printf("%I64d\n",tot);
}
return 0;
}


最新文章

  1. netty5 HTTP协议栈浅析与实践
  2. openvpn安装
  3. hihoCoder 1309:任务分配 贪心 优先队列
  4. HDU3820 Golden Eggs(最小割)
  5. Mysql基础1
  6. 更改chrome底色为护目色
  7. 验证坐标在某片坐标区域内 php 代码
  8. Jqgrid获取行id
  9. CSS之拖拽1
  10. rqnoj-396-SY学语文-dp
  11. django的Model 模型中常用的字段类型
  12. 【DWM1000】 code 解密5一ACHOR 第一次回家Main 函数
  13. ssh生成私钥
  14. 第20章:MongoDB-聚合操作--聚合管道--$unwind
  15. 和我一起打造个简单搜索之ElasticSearch集群搭建
  16. gdb调试:
  17. 《图说VR入门》——入门汇总
  18. Leetcode: Binary Tree Inorder Transversal
  19. 第7章—SpringMVC高级技术—处理multipart形式的数据
  20. 在Hadoop中重写FileInputFormat类以处理二进制格式存储的整数

热门文章

  1. SpringCloud学习笔记(17)----Spring Cloud Netflix之服务网关Zuul的使用
  2. H5教程:移动页面性能优化
  3. VB学习笔记(一)VB操作字符串
  4. 51nod 1321 收集点心(最小割)
  5. hdu5321 beautiful set(莫比乌斯反演)
  6. #undef 的用法
  7. zoj 1655 单源最短路 改为比例+最长路
  8. YII进行数据查询及类库追踪
  9. C++primer读书笔记11-多态
  10. codeforces248(div1) B Nanami&amp;#39;s Digital Board