ROADS

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 12436 Accepted: 4591

Description

N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).

Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.

The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.

If such path does not exist, only number -1 should be written to the output.

Sample Input

5

6

7

1 2 2 3

2 4 3 3

3 4 2 4

1 3 4 1

4 6 2 1

3 5 2 0

5 4 3 2

Sample Output

11

Source

CEOI 1998

题目链接

id=1724">http://poj.org/problem?

id=1724

题意:你有K个点数,有N个点,M条边,一个maxcost。边为有向边(len。cost),求不超maxcost一条最短路

思路:spfa+一个if限制好像TLE

用dijkstra+优先队列优化

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
using namespace std;
int n,m;
struct node{
int y,di,fee;
node(int yy,int dii,int fe)
{
y=yy,di=dii,fee=fe;
}node(){}
bool operator < (const struct node a)const
{
if(a.di==di) return a.fee<fee;
return a.di<di;
}
}now,nex;
int maxx;
int dis[110];
vector<node> lin[110];
priority_queue<node> q;
int dj()
{
q.push(node(1,0,0));
while(!q.empty())
{
now=q.top(); q.pop();
if(now.y==n) return now.di;
for(int i=0;i<lin[now.y].size();i++)
{ if(now.fee+lin[now.y][i].fee<=maxx)
q.push(node(lin[now.y][i].y,now.di+lin[now.y][i].di,now.fee+lin[now.y][i].fee));
}
}
return -1;
} int main()
{
scanf("%d%d%d",&maxx,&n,&m);
for(int i=1;i<=m;i++)
{
int aa,bb,cc,dd;
scanf("%d%d%d%d",&aa,&bb,&cc,&dd);
lin[aa].push_back(node(bb,cc,dd));
}
printf("%d\n",dj()); }

最新文章

  1. TODO:Node.js pm2使用方法
  2. 手把手Maven搭建SpringMVC+Spring+MyBatis框架(超级详细版)
  3. PIC32MZ tutorial -- Change Notification
  4. 【推荐】iOS汉字转拼音第三方库
  5. Winform开发框架之权限管理系统改进的经验总结(4)-一行代码实现表操作日志记录
  6. Bitset 用法(STL)
  7. lintcode :搜索二维矩阵
  8. Learn Python The Hard Way学习笔记001
  9. js各种进制数之间的转换
  10. Java 并发编程(三)为线程安全类中加入新的原子操作
  11. MaxPooling的作用
  12. [FJWC2018]全排列
  13. TypeError: a bytes-like object is required, not &#39;str&#39;
  14. CCS中cmd文件的编写
  15. 安卓开发_浅谈主配置文件(AndroidManifest.xml)
  16. 2018.10.2浪在ACM 集训队第二次测试赛
  17. 构造函数与getter和setter的区别
  18. redis下操作Set和Zset
  19. vue项目优化
  20. 阿里官方Java代码规范标准《阿里巴巴Java开发手册》下载

热门文章

  1. python对象以及pickle腌制
  2. LR中日志参数的设置
  3. Codeforces_768_D_(概率dp)
  4. 类似倒圆角方法输入半径选择实体 kword
  5. elk大纲
  6. 关于C++中字符串输入get与getline的区别
  7. LINUX-挂载一个文件系统
  8. textbook references
  9. [bzoj4567][Scoi2016][背单词] (贪心+trie树)
  10. CSS中具有继承性的属性: