Nice boat

Time Limit: 30000/15000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 47 Accepted Submission(s): 10

Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli. Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died. Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest. There is a hard data structure problem in the contest: There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2). You should output the final sequence.
Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n separated by a single space.
The next line contains an integer Q, denoting the number of the operations.
The next Q line contains 4 integers t,l,r,x. t denotes the operation type. T<=2,n,Q<=100000
a_i,x >=0
a_i,x is in the range of int32(C++)
Output
For each test case, output a line with n integers separated by a single space representing the final sequence.
Please output a single more space after end of the sequence
Sample Input
1
10
16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709
10
1 3 6 74243042
2 4 8 16531729
1 3 4 1474833169
2 1 8 1131570933
2 7 9 1505795335
2 3 7 101929267
1 4 10 1624379149
2 2 8 2110010672
2 6 7 156091745
1 2 5 937186357
Sample Output
16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149

给出n个数。两种操作,1 a b x 将a到b的全部数改动为x, 2 a b x将在a到b范围内的全部大于x的数改动为与x的最大公约数

范围改动值不说。在[a,b]内的全部大于x的数 与x去最大公约数,逐步向下分区间,假设该区间都被改动了,而且改动的值大于x。将改动的值于x去最大公约数,否则,继续向下分区间。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int tree[2000000] , u[2000000] ;
int gcd(int a,int b)
{
return b == 0 ? a : gcd(b,a%b);
}
void init(int o,int x,int y)
{
if(x == y)
scanf("%I64d", &tree[o]);
else
{
int mid = (x + y) / 2 ;
init(o*2,x,mid);
init(o*2+1,mid+1,y);
}
}
void f(int o,int x,int y)
{
if( u[o] != -1 )
{
u[o*2] = u[o*2+1] = u[o] ;
u[o] = -1 ;
if(y = x + 1)
tree[o*2] = tree[o*2+1] = u[o] ;
}
}
void update1(int o,int x,int y,int l,int r,int k)
{
if( l <= x && y <= r )
u[o] = k ;
else
{
f(o,x,y) ;
int mid = (x + y) / 2 ;
if( l <= mid )
update1(o*2,x,mid,l,r,k);
if( mid+1 <= r )
update1(o*2+1,mid+1,y,l,r,k);
}
}
void update2(int o,int x,int y,int l,int r,int k)
{
if(x == y && u[o] == -1 )
{
if( tree[o] > k )
tree[o] = gcd(tree[o],k);
return ;
}
if( l <= x && y <= r && u[o] != -1 )
{
if( u[o] > k )
u[o] = gcd(u[o],k);
}
else
{
f(o,x,y) ;
int mid = (x + y) / 2 ;
if( l <= mid )
update2(o*2,x,mid,l,r,k);
if( mid+1 <= r )
update2(o*2+1,mid+1,y,l,r,k);
}
}
int sum(int o,int x,int y,int k)
{
int ans = 0 ;
if( x <= k && k <= y && u[o] != -1 )
return u[o] ;
if( x == y && x == k )
return tree[o] ;
else
{
int mid = (x + y) / 2 ;
if( k <= mid )
ans = sum(o*2,x,mid,k);
else
ans = sum(o*2+1,mid+1,y,k);
}
return ans ;
}
int main()
{
int T , n , m , t , l , r , x , i ;
scanf("%d", &T);
while(T--)
{
memset(tree,0,sizeof(tree));
memset(u,-1,sizeof(u));
scanf("%d", &n);
init(1,1,n);
scanf("%d", &m);
while(m--)
{
scanf("%d %d %d %d", &t, &l, &r, &x);
if(t == 1)
update1(1,1,n,l,r,x);
else
update2(1,1,n,l,r,x);
}
for(i = 1 ; i <= n ; i++)
{
int ans = sum(1,1,n,i);
printf("%d ", ans);
}
printf("\n");
}
return 0;
}

最新文章

  1. centos7下使用yum安装mysql
  2. fineui刷新父页面
  3. Web jquery表格组件 JQGrid 的使用 - 11.问题研究
  4. 线上任务的mysql 重启
  5. AFNetworking 2.5.0版本的使用
  6. 有关基于模型的设计(MBD)一些概念和理解(zz)
  7. sell-- wordPOI
  8. 6-10k招几个.NET开发工程师(工作地点:成都)
  9. Bash判断文件是否存在
  10. php 邮件发送代码-php邮件群发
  11. ubuntu vim YCM
  12. 分享几个实用的jquery工具函数
  13. require include php5中最新区别,百度上好多错的。
  14. 【前端】nodejs的ORM框架sequelize的工厂化
  15. dephi FillChar 的几种写法
  16. 逆向工程vgenerator(一)
  17. final关键字。
  18. 为何GET只发一次TCP连接,POST发两次TCP连接
  19. From传值
  20. 集合框架 ArrayList LinkedList(待续)

热门文章

  1. java_日期和时间
  2. python关于入参中,传入的是指针还是引用
  3. Visual Studio 安装VS10x CodeMAP
  4. WebGL 绘制Line的bug(一)
  5. iOS开发基础知识
  6. poj 1664放苹果(转载,不详细,勿点)(递归)
  7. L2-2 社交集群 (25 分)(一个写挫的并查集)
  8. 深搜DFS
  9. 1.INFORMATION_SCHEMA简介
  10. python022 Python3 面向对象