This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade**Fgrade**M. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA
思路
  • 跟之前的PTA(Basic Level)1028.人口普查仍旧有点像,不过这里要分男女情况来比较。不过比较的内容是分数,和之前相比算简单的了
代码
#include<bits/stdc++.h>
using namespace std;
struct student
{
char name[20];
char gender;
char id[20];
int grade;
}female_high, male_low; void Init()
{
female_high.grade = -1;
male_low.grade = 110;
} bool higher(student a, student b)
{
return a.grade > b.grade;
} int main()
{
int n;
Init();
scanf("%d", &n);
student tmp;
while(n--)
{
scanf("%s %c %s %d", tmp.name, &tmp.gender, tmp.id, &tmp.grade);
if(tmp.gender == 'M' && higher(male_low, tmp))
male_low = tmp;
if(tmp.gender == 'F' && higher(tmp, female_high))
female_high = tmp;
} bool absent = false;
if(female_high.grade == -1)
{
printf("Absent\n");
absent = true;
}else printf("%s %s\n", female_high.name, female_high.id);
if(male_low.grade == 110)
{
printf("Absent\n");
absent = true;
}else printf("%s %s\n", male_low.name, male_low.id);
if(absent)
printf("NA");
else printf("%d", female_high.grade - male_low.grade);
return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805453203030016

最新文章

  1. 【Chrome】新建Chrome插件,新建,事件行为,本地存储
  2. CodeIgniter 开发,支付宝接口调用实例
  3. Win10外包公司——长年承接Win10App外包、Win10通用应用外包
  4. 三步解决EntityFramework Code First中的MissingMethodException错误
  5. 函数式编程之block
  6. poj 3264 Balanced Lineup (线段树)
  7. PHPCMS教程
  8. Moebius实现Sqlserver集群~介绍篇
  9. JS正则表达式验证数字非常全
  10. [LeetCode OJ] Gas Station
  11. sphinx (coreseek)——3、区段查询 与 增量索引实例
  12. CSS - 解决使用浮动,父窗体不能撑高问题
  13. 【ASP.NET】怎样使用类创建公共函数,在不同ASP.NET页面间反复调用
  14. UOJ 275. 【清华集训2016】组合数问题
  15. [数据结构] 2.2 Huffman树
  16. 自学Linux Shell3.2-切换目录命令cd
  17. AFNetworking 2.5.x 网络请求的封装
  18. 1260. [CQOI2007]涂色【区间DP】
  19. Mac下如何进行端口转发,方便一系列需要使用80端口进行的调试工作
  20. ubuntu下pycharm快捷方式创建

热门文章

  1. Laravel dingo,HTTP的请求头(accept)无法携带版本号的解决方法
  2. JVM(九),垃圾回收回收算法
  3. vps能ping通但是ssh无法连接
  4. 快速乘(O(1))
  5. [题解] [CF451E] Devu and Flowers
  6. Inter IPP &amp; Opencv 在centos 环境下使用GCC命令行编译c++运行
  7. ARTS打卡计划第三周
  8. Linux下压缩和解压命令
  9. 关于colab的一些技巧
  10. LeetCode 23. 合并K个排序链表(Merge k Sorted Lists)