problem

1003 Emergency (25)(25 point(s))
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible. Input Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2. Output For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.\ All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line. Sample Input 5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1 Sample Output 2 4

anwser

Dijkstra 解法
#include<bits/stdc++.h> #define INF 0x3f3f3f3f
#define Max 511 int N, M, C1, C2;
int Rescue[Max], Map[Max][Max], Dis[Max], Pre[Max], W[Max], Diff[Max];
bool Vis[Max] = {false}; void Dijkstra(int s){
memset(Dis, INF, sizeof(Dis));
memset(W, 0, sizeof(W));
memset(Diff, 0, sizeof(Diff)); Dis[s] = 0;
W[s] = Rescue[s];
Diff[s] = 1;
for(int i = 0; i < N; i++) Pre[i] = i; for(int i = 0; i < N; i++){
int u = 0, minn = INF;
for(int j = 0; j < N; j++){
if(!Vis[j] && Dis[j] < minn){
u = j;
minn = Dis[j];
}
} if(u == C2 || minn == INF) return;
Vis[u] = true; for(int v = 0; v < N; v++) {
if(!Vis[v]) {
if(Dis[u] + Map[u][v] < Dis[v]){
Dis[v] = Dis[u] + Map[u][v];
// Pre[v] = u;
// }
W[v] = W[u] + Rescue[v];
Diff[v] = Diff[u];
}else if (Dis[u] + Map[u][v] == Dis[v]){
Diff[v] += Diff[u];
if(W[u] + Rescue[v] > W[v]){
W[v] = W[u] + Rescue[v];
// Pre[v] = u;
}
} }
}
}
} int main(){
// freopen("test.txt", "r", stdin); memset(Map, INF, sizeof(Map)); std::cin>>N>>M>>C1>>C2;
for(int i = 0; i < N; i++){
std::cin>>Rescue[i];
} for(int i = 0; i < M; i++){
int c1, c2, L;
std::cin>>c1>>c2>>L;
Map[c1][c2] = Map[c2][c1] = L;
} Dijkstra(C1); std::cout<<Diff[C2]<<" "<<W[C2]; return 0;
} /*
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
*/
DFS解法

#include<bits/stdc++.h>
#include<vector> #define INF 0x3f3f3f3f
#define Max 511 int N, M, C1, C2;
int Rescue[Max], Map[Max][Max], Dis[Max], Pre[Max], W[Max], Diff[Max];
bool Vis[Max] = {false}; void Dijkstra(int s){
memset(Dis, INF, sizeof(Dis));
memset(W, 0, sizeof(W));
memset(Diff, 0, sizeof(Diff)); Dis[s] = 0;
W[s] = Rescue[s];
Diff[s] = 1;
for(int i = 0; i < N; i++) Pre[i] = i; for(int i = 0; i < N; i++){
int u = 0, minn = INF;
for(int j = 0; j < N; j++){
if(!Vis[j] && Dis[j] < minn){
u = j;
minn = Dis[j];
}
} if(u == C2 || minn == INF) return;
Vis[u] = true; for(int v = 0; v < N; v++) {
if(!Vis[v]) {
if(Dis[u] + Map[u][v] < Dis[v]){
Dis[v] = Dis[u] + Map[u][v];
W[v] = W[u] + Rescue[v];
Diff[v] = Diff[u];
}else if (Dis[u] + Map[u][v] == Dis[v]){
Diff[v] += Diff[u];
if(W[u] + Rescue[v] > W[v]){
W[v] = W[u] + Rescue[v];
}
} }
}
}
} int minDis = INF, diff = 0, maxTeam = 0, vis[Max]; void DFS(int v, int dis, int team){
if(v == C2){
if(dis < minDis)
{
minDis = dis;
diff = 1;
maxTeam = team;
}else if(dis == minDis){
diff++;
if(team > maxTeam) maxTeam = team;
}
// std::cout<<team<<std::endl;
return ;
}
vis[v] = 1;
for(int i = 0; i < N; i++)
if(vis[i] == 0 && Map[v][i] != INF)
DFS(i, dis + Map[v][i], team + Rescue[i]);
vis[v] = 0;
} int main(){
// freopen("test.txt", "r", stdin); memset(Map, INF, sizeof(Map));
memset(vis, 0, sizeof(vis)); std::cin>>N>>M>>C1>>C2;
for(int i = 0; i < N; i++){
std::cin>>Rescue[i];
} for(int i = 0; i < M; i++){
int c1, c2, L;
std::cin>>c1>>c2>>L;
Map[c1][c2] = Map[c2][c1] = L;
} // Dijkstra(C1);
// std::cout<<Diff[C2]<<" "<<W[C2]; DFS(C1, 0, Rescue[C1]);
std::cout<<diff<<" "<<maxTeam; return 0;
} /*
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
*/

experience

  • 注意审题,求的不是最短路,是最短路的不同路条数。
  • 这个图不是单向图,是双向图。
  • Dijkstra算法以及其变种需要熟悉。

    单词复习
  • scattered 分散的

最新文章

  1. mybatis配置文件的bug
  2. IOS开发基础知识--碎片29
  3. Intent之复杂数据的传递
  4. switch...case和if...else if的判断应用
  5. Convert between cv::Mat and QImage 两种图片类转换
  6. JAVA OOP 基础知识提纲
  7. 用word写博客
  8. Oracle 怎么让id自增加
  9. springmvc学习(三)
  10. [Cache] C#操作缓存--CacheHelper缓存帮助类 (转载)
  11. Delphi中WideString类型如何转化成String类型
  12. poj 3671 Dining Cows (Dp)
  13. ref - 按引用传递参数
  14. javascript windows对象
  15. 【canvas系列】canvas实现&quot;雷达扫描&quot;效果
  16. Asp.net实现下拉框和列表框的连动
  17. git rebase 合并多次提交.
  18. 教你如何绘制数学函数图像——numpy和matplotlib的简单应用
  19. Springboot Application 集成 OSGI 框架开发
  20. centos7下安装docker(25docker swarm---replicated mode&amp;global mode)

热门文章

  1. url参数用&amp;拼接并且按照字母顺序排序方法
  2. 利用Object.defineProperty 简化 Chrome插件本地存储操作
  3. windows程序设计.窗口.
  4. sparse coding
  5. python3实现socket通信
  6. Scrapy官网程序执行示例
  7. XP远程连接Win10,提示【远程计算机需要网络级别身份验证,而您的计算机不支持该验证】
  8. 日期时间设置 &quot;2018-05-04T16:36:23.6341371+08:00&quot; 格式
  9. 关于move
  10. 关于Eclipse连接sql server 2008的若干问题