A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 260585    Accepted Submission(s): 50389

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<stdio.h>
#include<string.h>
#define MAX 1100
char str1[MAX],str2[MAX];
int a[MAX],b[MAX];
int main()
{
int n,m,j,i,s,t,l1,l2,k,ok;
scanf("%d",&t);
k=1;
while(t--)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%s%s",str1,str2);
l1=strlen(str1);
l2=strlen(str2);
for(i=l1-1,j=0;i>=0;i--)
{
a[j]=str1[i]-'0';
j++;
}
for(i=l2-1,j=0;i>=0;i--)
{
b[j]=str2[i]-'0';
j++;
}
n=0;
if(l1<l2)
{
n=l1;
l1=l2;
l2=n;
}
for(i=0;i<l1;i++)
{
a[i]=a[i]+b[i];
if(a[i]>=10)
{
a[i]-=10;
a[i+1]++;
}
}
ok=0;
if(a[l1]>0)
{
ok=1;
}
printf("Case %d:\n",k++);
printf("%s + %s = ",str1,str2);
if(!ok)
for(i=l1-1;i>=0;i--)
printf("%d",a[i]);
else
for(i=l1;i>=0;i--)
printf("%d",a[i]);
printf("\n");
if(t)
printf("\n");
}
return 0;
}

最新文章

  1. (二十)WebGIS中图层树功能的设计和实现
  2. 自爽:DOTNET 笔试题
  3. 通过使用ScriptManager.RegisterStartupScript,呈现后台多次使用alert方法
  4. POJ 1135 Domino Effect(Dijkstra)
  5. workerman需要的php模块posix、pcntl、sysvshm、sysvmsg缺少,怎么办
  6. 单点登录CAS使用记(八):使用maven的overlay实现无侵入的改造CAS
  7. POJ3641 Pseudoprime numbers(快速幂+素数判断)
  8. [ACdream]女神教你字符串——违和感
  9. How to SetUp The Receiving Transaction Manager
  10. delphi
  11. 控制结构(4): 局部化(localization)
  12. Redis高可用 Sentinel
  13. 读写分离子系统 - C# SQL分发子系统(目前只支持ADO.NET)
  14. java内存模型与volatile变量与Atomic的compareAndSet
  15. vue-cli,build 后,报错的解决办法
  16. [LeetCode] 183. Customers Who Never Order_Easy tag: SQL
  17. Win10版本号区分
  18. 虚拟机安装MAC OS X 10.9与Windows 7共享文件夹的方法
  19. Ubuntu 下安装sqlite3 及常用SQL 语句
  20. 【剑指Offer学习】【面试题22:栈的压入、弹出序列】

热门文章

  1. event的属性
  2. cmake 安装 mysql
  3. torch7在mac上的安装
  4. C语言-06复杂数据类型-01数组
  5. Navigation学习笔记
  6. Laravel 安装记录
  7. ipad ------ 与iPhone的差别
  8. JS单元测试框架:QUnit
  9. spirng MVC乱码过滤器
  10. 字符串匹配的KMP算法(转)