题目链接:

id=2105">http://poj.org/problem?id=2105

----------------------------------------------------------------------------------------------------------------------------------------------------------
欢迎光临天资小屋http://user.qzone.qq.com/593830943/main

----------------------------------------------------------------------------------------------------------------------------------------------------------

Description

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at
a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary
systems are:

27   26  25  24  23   22  21  20 

128 64  32  16  8   4   2   1 

Input

The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

Output

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

Sample Input

4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001

Sample Output

0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1

题意:非常easy, 就是每一个案例给出一个32位的2进制数字串。 要求依照每8位转换为8进制输出(中间有‘.’)就可以!

代码例如以下:

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int N;
int i, j;
char s[117];
while(cin >> N)
{
while(N--)
{
cin>>s;
int ans[4], k = 7, l = 0;
int sum = 0;
for(i = 0; i < 32; i++)
{
sum +=(s[i]-'0')*pow(2.0,k);
k--;
if(i%8==7)
{
ans[l++] = sum;
sum = 0;
k = 7;
}
}
cout<<ans[0]<<'.'<<ans[1]<<'.'<<ans[2]<<'.'<<ans[3]<<endl;
}
}
return 0;
}

最新文章

  1. Tomcat重启脚本restart.sh停止脚本stop.sh
  2. [HTML/HTML5]5 使用链接
  3. Android手机的上网功能需要用到APN(网络接入点)的设置 电信
  4. WPF 颜色转换
  5. Java NIO 开篇
  6. sed的惯常用法
  7. sdut 2831 Euclid (几何)
  8. C#中调用unmanaged DLL
  9. Cocos2d-x Box2D物理引擎编译设置
  10. C#采用的是“四舍六入五成双”、上取整、下取整
  11. “学习CSS布局” 笔记
  12. Vue基本使用和指令集
  13. PHP原生处理select结果集的函数介绍
  14. Go语言模拟实现简单的区块链
  15. 关于 数据库 my_slq的 安装及其卸载
  16. 使用GitHub Pages + Jekyll 建立博客
  17. Go_17:GoLang中如何使用多参数属性传参
  18. asp.net 获取音视频时长 的方法
  19. ajax 跨域访问 :Access-Control-Allow-Origin
  20. java基础语法this关键字

热门文章

  1. Java [Leetcode 110]Balanced Binary Tree
  2. 省常中模拟 Test2 Day2
  3. SVN版本管理提示信息
  4. shell 删除日志
  5. Asp.Net MVC4 系列-- 进阶篇之路由(1)【转】
  6. .NET之美——.Net 项目代码风格要求
  7. webdriver(python)学习笔记五——层级定位
  8. &lt;译&gt;Selenium Python Bindings 4 - Locating Eelements
  9. WEB安全性测试测试用例(基础)
  10. LoadRunner检查点实战