Problem D

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

代码:

#include<stdio.h>
#include<string.h>

int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int t,n,m,a[10001],b[10001],dp[10001],i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=0;i<n;i++)
        {
            scanf("%d",&b[i]);
        }
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
        {
            for(j=m;j>=b[i];j--)
            {
                dp[j]=max(dp[j],dp[j-b[i]]+a[i]);
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}

最新文章

  1. Django 之 ForeignKey、ManyToMany的访问方式
  2. javascript 常用实用函数。。。。。。
  3. 百度地图简单使用——添加折线,圆形等(html,js)
  4. vc编译器 msvcr.dll、msvcp.dll的含义和相关错误的处理
  5. 【C疯狂的教材】(九)C语言指针(一)
  6. MSDN官方XmlSerializer类导致内存泄漏和性能低
  7. CSS 实现的各种球体效果
  8. vue脚手架的使用
  9. SNMP支持IPv6
  10. javaweb三大框架和MVC设计模式
  11. java中的自定义注解的使用
  12. unix环境高级编程----进程控制wait()
  13. redis在.net架构中的应用(1)--利用servicestack连接redis
  14. STM32的System memory
  15. 单词转换成向量形式 word2vec
  16. JavaScript 开发的45个技巧
  17. IE中使用TerraExplorerPro ActiveX控件问题总结
  18. android 仿真器联网
  19. XML 的解析方法
  20. Web Pages(单页面模型)

热门文章

  1. bzoj2597
  2. JAVA中IO技术:BIO、NIO、AIO
  3. NHibernate 存储过程使用
  4. Objective-c初始化和便利构造
  5. mac上的键盘生活——quicksliver
  6. ACM1230_火星A+B(进位的运算)
  7. java IO复习(三)
  8. hdu 4762 Cut the Cake概率公式
  9. jsp文件中的alert等等
  10. zoj 1671 Walking Ant【简单bfs】