Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 
Sample Input
5
1 1
5 1
7 1
3 3
5 5
 
Sample Output
1
2
1
1
0
 

思路:

排序以后把在第二维上分治

#include <bits/stdc++.h>
using namespace std;
const double pi = acos(-1.0);
const int N = 1e5+7;
const int inf = 0x3f3f3f3f;
const double eps = 1e-6;
typedef long long ll;
const ll mod = 1e9+7;
struct node{
int x,y,id;
friend bool operator < (node a,node b){
if(a.x!=b.x) return a.x<b.x;
return a.y<b.y;
}
}p[N],a[N];
int f[N];
int ans[N];
void cdq(int l,int r){
if(l==r) return ;
int mid=(l+r)>>1;
cdq(l,mid); cdq(mid+1,r);
int i=l,j=mid+1,cnt=l;
while(i<=mid&&j<=r){
if(p[i].y<=p[j].y){
a[cnt++]=p[i++];
}else{
f[p[j].id]+=(i-l);
a[cnt++]=p[j++];
}
}
while(i<=mid) a[cnt++]=p[i++];
while(j<=r){
f[p[j].id]+=(i-l);
a[cnt++]=p[j++];
}
for(int k=l;k<=r;k++) p[k]=a[k];
}
int main(){
// ios::sync_with_stdio(false);
// cin.tie(0); cout.tie(0);
int n;
while(~scanf("%d",&n)){
memset(f,0,sizeof(f));
memset(ans,0,sizeof(ans));
for(int i=1;i<=n;i++){
int x,y; scanf("%d%d",&x,&y);
p[i]=node{x,y,i};
}
sort(p+1,p+n+1);
cdq(1,n);
for(int i=1;i<=n;i++)
ans[f[i]]++;
for(int i=0;i<n;i++)
printf("%d\n",ans[i]);
}
return 0;
}

最新文章

  1. ng-repeat
  2. JavaScript中Promises/A+规范的实现
  3. Razor 模板自己渲染出结果 string
  4. 轻快的VIM(三):删除
  5. C#高级功能(一)Lambda 表达式
  6. Could not load the &quot;btn_020.disable.png&quot; image referenced from a nib in the bundle with identifier &quot;com.xxx.---0710&quot;
  7. 屏蔽全部统计代码(51.la cnzz 百度统计 谷歌分析师adsense、屏蔽淘宝客广告代码)的方法
  8. iOS 9之New UIKit for International User Interfaces
  9. Pick two points at random from the interior of a unit square, what is the expected distance between them?
  10. ActionForward
  11. 寻求c++解答如下三个题目!
  12. jquery ui 笔记
  13. 【MySQL】Linux下MySQL 5.5、5.6和5.7的RPM、二进制和源码安装
  14. 在Spring Boot中使用swagger-bootstrap-ui
  15. java 线程方法 ---- wait()
  16. 网页验证码出不来,读取验证码时出错:javax.imageio.IIOException: Can&#39;t create cache file!
  17. Spark 异步Action
  18. mac nginx 启动 自启动
  19. Broken Keyboard (a.k.a. Beiju Text) 思路
  20. layui checkbox无法显示出来问题

热门文章

  1. 500 份源码合集——GitHub 热点速览 v.21.02
  2. aix5.3安装httpd服务
  3. 【老孟Flutter】2021 年 Flutter 官方路线图
  4. 基于 MPI 的快速排序算法的实现
  5. 解决Cannot find module &#39;@angular/compiler-cli&#39;
  6. kubernets之pod的标签
  7. pandas 写csv 操作
  8. cmd的终结工具cmder
  9. B树的进化版----B+树
  10. 干货!上古神器 sed 教程详解,小白也能看的懂