There is an objective test result such as \OOXXOXXOOO". An `O' means a correct answer of a problemand an `X' means a wrong answer. The score of each problem of this test is calculated by itself andits just previous consecutive `O's only when the answer is correct. For example, the score of the 10thproblem is 3 that is obtained by itself and its two previous consecutive `O's.Therefore, the score of \OOXXOXXOOO" is 10 which is calculated by \1+2+0+0+1+0+0+1+2+3".You are to write a program calculating the scores of test results.InputYour program is to read from standard input. The input consists ofTtest cases. The number of testcasesTis given in the rst line of the input. Each test case starts with a line containing a stringcomposed by `O' and `X' and the length of the string is more than 0 and less than 80. There is no spacesbetween `O' and `X'.OutputYour program is to write to standard output. Print exactly one line for each test case. The line is tocontain the score of the test case.

Sample Input

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output

10

9

7

5

5

30

解析:根据次数判加几

ac代码

#include<iostream>
#include<string>
using namespace std;
int main()
{
    string s;
    int n;
    cin>>n;
    getchar();
    while(n--)
    {
        getline(cin,s);
        int ans=0,flag=0;
        for(int i=0; i<s.length(); i++)
        {
            if(s[i]=='O')
            {
                flag++;
                ans+=flag;
            }
            else
                flag=0;
        }
        cout<<ans<<endl;
    }
    return 0;
}

最新文章

  1. Nginx 1.10.1 编译、配置文档(支持http_v2,TLSv1.2,openssl v1.0.2)
  2. oracle修改字符集
  3. 【CodeForces 699D】Fix a Tree
  4. The import java.util cannot be resolved The import javax.servlet cannot be resolved
  5. win7下MariaDB10.0的my.ini配置文件的位置
  6. Linux时间与Windows差8个时区的问题解决方法
  7. python描述符descriptor(一)
  8. Yii PHP 框架分析 (一)
  9. 构建高性能WEB站点笔记三
  10. java switch 优化
  11. 遇到delphi连接sql一个奇怪的问题:未指定的错误,加大了命令的等待时间为600即可了
  12. php 中的closure用法
  13. 控制结构(9) 管道(pipeline)
  14. js中判断undefined类型
  15. CSS3 神器总结
  16. python并发_线程
  17. maven学习四:maven集成jetty插件发布web项目 标签: maven
  18. Java面试题精选,大型网站系统架构你不得不懂的10个问题
  19. 码云IntelliJ IDEA
  20. chmod修改权限

热门文章

  1. 暑假集训day1 水题 乘法最大
  2. 入门大数据---Spark_Streaming基本操作
  3. ajax前后端交互原理(1)
  4. MFC中窗口静态分割&amp;视图切换
  5. 为什么 group by后面 必须跟selecte 后面的除了聚集函数外的所有字段
  6. Material Component--mdcChipSet使用
  7. 03.springboot 整合RabbitMQ
  8. DNS域名解析服务的介绍
  9. NumPy基础知识图谱
  10. 一篇文章教会你如何将DOM转换为virtual DOM