有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

Input

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

Output

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。 

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input

4 3
1 2
2 3
4 3

Sample Output

1 2 4 3

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<vector>
#include<cmath> const int maxn=1e5+5;
typedef long long ll;
using namespace std;
vector<int>edge[505];
int in[505];
int n,m;
void init()
{
for(int t=1;t<=n;t++)
edge[t].clear();
memset(in,0,sizeof(in));
}
void TPsort()
{
priority_queue<int,vector<int>, greater<int> >q;
for(int t=1;t<=n;t++)
{
if(in[t]==0)
{
q.push(t);
}
}
vector<int>ans;
while(!q.empty())
{
int k=q.top();
q.pop();
ans.push_back(k);
for(int t=0;t<edge[k].size();t++)
{
int s=edge[k][t];
in[s]--;
if(in[s]==0)
{
q.push(s);
}
}
}
for(int t=0;t<ans.size();t++)
{
if(t!=ans.size()-1)
cout<<ans[t]<<" ";
else
{
cout<<ans[t]<<endl;
} }
}
int main()
{
while(cin>>n>>m)
{
int a,b;
init();
for(int t=0;t<m;t++)
{
scanf("%d%d",&a,&b);
edge[a].push_back(b);
in[b]++;
}
TPsort();
}
return 0;
}

最新文章

  1. Java堆和栈详解
  2. DS实验题 Searchname
  3. ActionErrors 使用说明 struts1 validate 处理流程 详细教程(转)
  4. 服务器能访问共享,但是ping不通解决方案
  5. matplotlib python高级绘图库 一周总结
  6. IO 延迟与Queue Depth
  7. webstore+nodejs
  8. Azure File SMB3.0文件共享服务(4)
  9. PHP基础示例:简单的在线文件管理
  10. 推荐一个比HtmlWebpackPlugin更灵活的插件
  11. Build Tools
  12. delphi 调用QQ邮箱发送邮件
  13. 微信小程序 Video默认横屏
  14. python运算符,数据类型,数据类型操作,三目运算,深浅拷贝
  15. Python基础3 函数、递归、内置函数
  16. codeforces round#509
  17. BZOJ1922:[SDOI2010]大陆争霸(最短路)
  18. stuff in /proc/sys/fs/
  19. 《算法竞赛入门经典》习题及反思 -&lt;2&gt;
  20. Python - 更改pip源至国内镜像

热门文章

  1. axure可用密钥
  2. 十二.filter
  3. linux c 获取系统时间
  4. 权限管理RBAC
  5. Windows下用Nginx配置遇到的问题
  6. C# DateTime.ToString()的各种日期格式
  7. [GO]切片和底层数组的关系
  8. Java 起名规范
  9. C# -- 泛型(3)
  10. DB2 函数快速构造测试数据