Binary Tree Traversals

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the
vertices of T, we visit the root r followed by visiting the vertices of
T1 in preorder, then the vertices of T2 in preorder.

In an
inorder traversal of the vertices of T, we visit the vertices of T1 in
inorder, then the root r, followed by the vertices of T2 in inorder.

In
a postorder traversal of the vertices of T, we visit the vertices of T1
in postorder, then the vertices of T2 in postorder and finally we visit
r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

 

Input

The
input contains several test cases. The first line of each test case
contains a single integer n (1<=n<=1000), the number of vertices
of the binary tree. Followed by two lines, respectively indicating the
preorder sequence and inorder sequence. You can assume they are always
correspond to a exclusive binary tree.
 

Output

For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
 

Sample Output

7 4 2 8 9 5 6 3 1
 
不知道为什么往函数里串地址就运行不了,找了半天没找到错误!
 这是错误的代码:

#include <stdio.h>
#include <string.h>
int n;
int a[1000], b[1000], c[1000]; void build( int len, int s1, int s2, int s )
{
int p;
int i;
if(len<=0)
return;
else
{
for(i=s2; i<s2+len; i++ )
{
if(b[i]==a[s1])
{
p = i;
break;
}
}
c[s+len-1] = a[s1]; build(p, s1+1, s2, s ); //左
build(len-p-1, s1+p+1, s2+p+1, s+p); //右 }
}
int main()
{
int i, j;
while(scanf("%d", &n)!=EOF)
{
for(i=0; i<n; i++)
{
scanf("%d", &a[i] );
}
for(i=0; i<n; i++)
{
scanf("%d", &b[i] );
}
build(n, 0, 0, 0); for(i=0; i<n; i++)
{
printf("*%d ", c[i] );
}
} return 0;
}
 
这是正确的代码:
 
#include <stdio.h>
#include <string.h>
void build(int len, int *s1, int *s2, int *s)
{
int p;
int i;
if(len<=0)
return; else
{
for(i=0; i<len; i++)
{
if(s2[i]==s1[0])
{
p = i;
}
}
build(p, s1+1, s2, s);
build(len-p-1, s1+p+1, s2+p+1, s+p);
s[len-1] = s1[0];
}
}
int main()
{
int i; int s1[1000], s2[1000], s3[1000];
int n;
while(scanf("%d", &n)!=EOF)
{
for(i=0; i<n; i++)
{
scanf("%d", &s1[i] );
}
for(i=0; i<n; i++)
{
scanf("%d", &s2[i] );
}
build(n, s1, s2, s3 );
for(i=0; i<n; i++)
{
printf("%d%c", s3[i], i==n-1?'\n':' ' );
}
} return 0;
}

最新文章

  1. HTTP协议 (五) 代理
  2. [转载] 数据库分析手记 —— InnoDB锁机制分析
  3. L012-oldboy-mysql-dba-lesson12
  4. windows向ubuntu过渡之常用软件安装
  5. iscroll横向滑动(当前页状态标记自动变化)
  6. Lucky and Good Months by Gregorian Calendar(模拟)
  7. Nagios配置—添加linux主机监控
  8. http multipart/form-data POST文件上传详解
  9. lucene 索引删除
  10. 兼容 console 没删除引起 低级浏览器 报错问题
  11. Apache 重启时会有报 AH00558
  12. Sublime Text3 编辑器我的最爱
  13. Python简单小程序练习
  14. Docker 基础技术之 Linux cgroups 详解
  15. longzhuapp项目笔记
  16. ubuntu系统安装mysql登陆提示 解决Mysql ERROR 1045 (28000): Access denied for user &#39;root&#39;@&#39;localhost&#39;问题
  17. 转载 R语言颜色基础设置
  18. python 一行代码字符串转字典方法
  19. c++ 静态函数
  20. netifd

热门文章

  1. CentOS LVS安装配置
  2. thread.join() 方法存在的必要性是什么?
  3. Unity3D性能优化之Draw Call Batching
  4. 动态注册HttpModule管道,实现global.asax功能
  5. 如何在Windows 10 IoT Core中添加其他语言的支持,如中文
  6. Java 异常介绍
  7. Java线程—-Runnable和Callable的区别和联系
  8. 浏览器登录cookie
  9. Zabbix二次开发_03api列表
  10. Solr6.5查询参数说明