题目链接

Problem Description

Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked

leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then

on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also

have known every object has its Center of Gravity.

Now,you have been given the coordinates of three points of a triangle. Can you calculate the center

of gravity of the triangle?

Input

The first line is an integer n,which is the number of test cases.

Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.

The input is terminated by n = 0.

Output

For each case, print the coordinate, accurate up to 1 decimal places.

Sample Input

2
1.0 2.0 3.0 4.0 5.0 2.0
1.0 1.0 4.0 1.0 1.0 5.0
0

Sample Output

3.0 2.7
2.0 2.3

分析:

三角形的三个点的坐标,求出这个三角形的重心。

X=(x0+x1+x2)/3;

Y=(y0+y1+y2)/3;

代码:

#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
double x[3];
double y[3];
int n;
while(~scanf("%d",&n),n)
{
while(n--)
{
scanf("%lf%lf%lf%lf%lf%lf",&x[0],&y[0],&x[1],&y[1],&x[2],&y[2]);
printf("%.1lf %.1lf\n",(x[0]+x[1]+x[2])/3,(y[0]+y[1]+y[2])/3);
}
}
return 0;
}

最新文章

  1. JavaScript 入门教程四 语言基础【2】
  2. 《JavaScript高级程序设计》读书笔记--前言
  3. 关于datatable linq的转换
  4. day11 堡垒机
  5. Nested List Weight Sum -- LeetCode 339
  6. 如何去掉delphi2010的欢迎界面(welcome page)
  7. ch2-4:遇到嵌套列表进行缩进打印
  8. run loop 输入源
  9. tomcat之JNDI数据源配置
  10. 移动端页面使用rem来做适配
  11. Could not allocate CursorWindow size due to error -12 错误解决方法
  12. 【Android - 进阶】之图片三级缓存的原理及实现
  13. 批处理中set截取字符具体解释
  14. @Autowired 和 @Resource
  15. SQL*Plus快速入门
  16. 用 CSS3 做一个流星雨动画
  17. 怎么去掉织梦网站首页带的index.html/index.php
  18. socket编程--相关函数--sendto();read();
  19. BZOJ1299 巧克力棒
  20. get改post

热门文章

  1. 【多线程】 Task ,async ,await
  2. (原)Android到IOS开发的转换(一)
  3. python 基础篇 13 迭代器与生成器
  4. Oracle to MySQL Goldengate实现增量迁移
  5. [HNOI2012]三角形覆盖问题
  6. C++ 学习笔记之——文件操作和文件流
  7. lintcode-127-拓扑排序
  8. CodeForces Round #521 (Div.3) E. Thematic Contests
  9. 【Linux】- ls命令详解
  10. Angular 2018 All in One