Moo University - Financial Aid

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 10894 Accepted: 3206

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,”Moo U” for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university’s limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.

Input

  • Line 1: Three space-separated integers N, C, and F

  • Lines 2..C+1: Two space-separated integers per line. The first is the calf’s CSAT score; the second integer is the required amount of financial aid the calf needs

Output

  • Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.

Sample Input

3 5 70

30 25

50 21

20 20

5 18

35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.


解题心得:

  1. 题意就是n个学生,每个学生有一个分数和去学校读书学校要给的钱,学校希望能够收取c个学生,要求这c个学生的花费总和不超过f并且要求这c个学生的中位数尽量大。
  2. 其实贪心的方法还是很简单,主要就是一个预处理,首先需要按照学生的分数来排序,然后预处理每个位置前面从c/2个学生花费最少是多少,后面的c/2个学生花费最少是多少。就是维护一个优先队列,优先队列之中需要放最小的c/2个最小的数,具体实现方法可以直接看代码。

#include <stdio.h>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long ll;
const int maxn = 1e5+100; struct Student {
ll sco,sp;
bool operator < (const Student &a) const {
return a.sco > sco;
}
}st[maxn]; ll sum_pre[maxn],sum_end[maxn];
ll n,c,f; void get_sum() {
priority_queue <int> qu;
ll sum = 0;
c = c/2; for(int i=n;i>n-c;i--) {
qu.push(st[i].sp);
sum += st[i].sp;
sum_end[i] = sum;
}
for(int i=n-c;i>=1;i--) {
if(st[i].sp <= qu.top()) {
sum -= qu.top() - st[i].sp;
qu.pop();
qu.push(st[i].sp);
}
sum_end[i] = sum;
} sum = 0;
while(!qu.empty())
qu.pop();
for(int i=1;i<=c;i++) {
sum += st[i].sp;
qu.push(st[i].sp);
sum_pre[i] = sum;
}
for(int i=c+1;i<=n;i++) {
if(st[i].sp < qu.top()) {
sum -= qu.top()-st[i].sp;
qu.pop();
qu.push(st[i].sp);
}
sum_pre[i] = sum;
}
} ll get_ans() {
for(int i=n-c;i>c;i--) {
ll sum = sum_pre[i-1] + sum_end[i+1];
sum += st[i].sp;
if(sum <= f)
return st[i].sco;
}
return -1;
} int main() {
scanf("%lld%lld%lld",&c,&n,&f);
for(int i=1;i<=n;i++)
scanf("%lld%lld",&st[i].sco,&st[i].sp);
sort(st+1,st+1+n);
get_sum();
ll ans = get_ans();
printf("%lld",ans);
return 0;
}

最新文章

  1. 如何在select下拉列表中添加复选框?
  2. javascript作用域链与原型链有联系吗?
  3. C#委托之泛型
  4. div紧靠浏览器底部
  5. C# 创建系统服务并定时执行【转载】
  6. [改善Java代码]对字符串排序 持一种宽容的心态
  7. sublime text3输入中文的问题.
  8. MySQL中的concat函数
  9. MyBatis之级联——一对一关系
  10. spring+springmvc+mybatis+oracle+atomikos+jta实现多数据源事务管理
  11. clientTop,scrollTop,兼容
  12. alpha-咸鱼冲刺day1
  13. 一步操作关闭iOS状态栏(电池栏)
  14. Docker私有仓库实例
  15. 微信小程序页面导航功能
  16. Java8-函数式接口理解及测试
  17. 解决:MVC对象转json包含\r \n
  18. Chrome 离线安装插件的办法
  19. or 的判断
  20. ubuntu查看文件和文件夹大小

热门文章

  1. Vue.js - Day3
  2. SASS简介及使用方法
  3. AndroidStudio多AppId多渠道快速打包
  4. SharePoint 2010 技术参数(整理)
  5. JavaScript 常用的Math对象
  6. *187. Repeated DNA Sequences (hashmap, one for loop)(difference between subsequence &amp; substring)
  7. 官方发布PHP语法规范
  8. 画X,模拟水题
  9. 在CentOS 6.5上安装NodeJS
  10. MyEclipse中安装findBugs插件(摘)