Strategic Game

Problem Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes

the description of each node in the following format

node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifier

or

node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input

4

0:(1) 1

1:(2) 2 3

2:(0)

3:(0)

5

3:(3) 1 4 2

1:(1) 0

2:(0)

0:(0)

4:(0)

Sample Output

1

2

一定要注意 不能把first数组或者fa数组初值设成零,因为这里有0这个点。。因为这个查了好久的错。。。。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n,tot=0,first[1505],nxt[1500*1505*2],v[1500*1500*2],fa[1505],ans=0;
bool vis[1505];
inline void add(int xx,int yy)
{
v[tot]=yy;
nxt[tot]=first[xx];
first[xx]=tot++;
}
bool dfs(int x)
{
for(int i=first[x];~i;i=nxt[i])
if(!vis[v[i]]){
vis[v[i]]=1;
if(fa[v[i]]==-1||dfs(fa[v[i]])){
fa[v[i]]=x;return true;
}
}
return false;
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
memset(first,-1,sizeof(first));
memset(fa,-1,sizeof(fa));
tot=ans=0;
for(int i=0;i<n;i++){
register int xx,yy,zz;
scanf("%d:(%d)",&xx,&yy);
for(int j=1;j<=yy;j++){
scanf("%d",&zz),add(zz,xx),add(xx,zz);
}
}
for(int i=0;i<n;i++){
memset(vis,0,sizeof(vis));
if(dfs(i)==1)ans++;
}
printf("%d\n",ans/2);
}
}

最新文章

  1. 兼容好的JS图片上传预览代码
  2. Python检查xpath和csspath表达式是否合法
  3. 操作系统开发系列—12.a.从Loader到内核 ●
  4. iOS开发实用干货——强化你的Xcode控制台
  5. android EditView ime
  6. 跟我学习dubbo-简介(1)
  7. CSS选择器详解(伪类) 转 http://blog.csdn.net/Panda_m/article/details/50084699
  8. crontab 基本用法
  9. Git分支学习总结
  10. shell之rm -rf的别名设置
  11. linux-redhat-iso 下载
  12. 拯救老旧工程,记桥接SpringMVC与Stripes框架
  13. python3编码
  14. Java 日志体系(二)jcl 和 slf4j
  15. mapper接口方法参数
  16. 多线程系列之九:Worker Thread模式
  17. HDU3605(KB11-M 状态压缩+最大流)
  18. Virtualenv教程
  19. 【Android】Android import和export使用说明 及 export报错:jarlist.cache: Resource is out of sync with the file syst解决
  20. tomcat 9.0.4 性能调优

热门文章

  1. Photoshop如何实现图片相对画布居中
  2. LINQ简记(3):子句
  3. 198. House Robber(动态规划)
  4. 联赛前集训日记Day1
  5. springboot之多任务并行+线程池处理
  6. Tomcat关闭后,重新启动,session中保存的对象为什么还存在解决方法
  7. Markdown 基本使用
  8. HBase行键的设计
  9. Groovy简单再入门
  10. mongodb之用户/认证/角色/权限管理