Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 14144    Accepted Submission(s): 6058

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.



On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.



Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.



When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.



If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).



Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 
Input
There are multiple cases (no more than 40 cases).



The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.



Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't
be put on the billboard, output "-1" for this announcement.
 
Sample Input
3 5 5
2
4
3
3
3
 
Sample Output
1
2
1
3
-1
 
Author
hhanger@zju
 
Source

field=problem&key=HDOJ+2009+Summer+Exercise%A3%A85%A3%A9&source=1&searchmode=source">HDOJ 2009 Summer Exercise(5)



十一点半了~  哎呀 !~   和sb疯一块儿刷题~。刚刷了一个线段树~ 好无聊……   明天 有是杭电多校联合 加油!

这个题目猛一看真的看不出来是线段数,还是做的线段树题目少啊。

公示牌儿的高度能够看作线段树根节点的长度,宽度能够看作,每一个节点的值,那么结构体元素须要一个保存每一个结点中可插入位置的最大值,因为update()函数性质恰好满足优先往左下角查询插入位置。一旦找到插入位置递归更新此点信息,并返回结果。

注意广告牌儿的高度

是一个幌子而已。然后就是代码了:

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
int h,x,n;
struct Tree
{
int left,right,Max;
} tree[200000<<2]; int create(int root ,int left,int right)
{
tree[root].left=left;
tree[root].right=right;
if(left==right)
{
return tree[root].Max=n;
}
int a,b,mid=(left+right)>>1;
a=create(root<<1,left,mid);
b=create(root<<1|1,mid+1,right);
return tree[root].Max=max(a,b);
} int update(int root,int w)
{
int res;
if(tree[root].left==tree[root].right)
{
tree[root].Max-=w;
return tree[root].left;
}
if(tree[root<<1].Max>=w)
res= update(root<<1,w);
else
res= update(root<<1|1,w);
tree[root].Max=max(tree[root<<1].Max,tree[root<<1|1].Max);
return res;
} int main()
{
while(cin>>h>>n>>x)
{
if(h>x)
h=x;
create(1,1,h);
for(int i=1; i<=x; i++)
{
int w;
scanf("%d",&w);
if(tree[1].Max<w)
printf("-1\n");
else
printf("%d\n",update(1,w));
}
}
}

最新文章

  1. [MySQL]MySQL之权限管理
  2. 界面排版-TableLayout的stretchColumns方法
  3. Android 定制下拉刷新头部 Ultra Pull To Refresh
  4. ASP.NET MVC3细嚼慢咽---(1)网站创建与发布
  5. spring读取加密配置信息
  6. 2 - SQL Server 2008 之 使用SQL语句为现有表添加约束条件
  7. 我在北京找工作(五):备战阿里巴巴java笔试&lt;1&gt;:筑基
  8. Binder的工作原理浅析
  9. NLP+词法系列(二)︱中文分词技术简述、深度学习分词实践(CIPS2016、超多案例)
  10. idea Library XXXXXXXX has broken classes paths
  11. 03_java基础(七)之面向对象
  12. scpclient使用报错fchmod无法找到问题解决
  13. 【php+微擎】微擎学习相关帮助推荐
  14. 【Unity】2.3 项目浏览器和资源的组织
  15. c#生成rsa公钥和私钥
  16. 小Q与内存
  17. RabbitMQ (十二) 消息确认机制 - 发布者确认
  18. MPLS基础一
  19. 1073 Scientific Notation
  20. Laravel系列之CMS系统学习 — 角色、权限配置【2】

热门文章

  1. LaTex的几种数学符号字体以及相关说明
  2. “.”开头,以&quot;}&quot;结尾,中间是任意字符的正则
  3. CDQ分治笔记
  4. CF915F Imbalance Value of a Tree (并查集)
  5. mysql联查中使用if和group by会让你的结果不是你想要的
  6. 紫书 例题8-10 UVa 714 (二分答案)
  7. CAD二次开发(01)-绘制直线
  8. [置顶] Netty学习总结(1)——Netty入门介绍
  9. POJ——T2553 The Bottom of a Graph
  10. 没用私服,自己安装下本地jar包,制作坐标