Hidden String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 803    Accepted Submission(s): 302

Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string s of
length n.
He wants to find three nonoverlapping substrings s[l1..r1], s[l2..r2], s[l3..r3] that:



1. 1≤l1≤r1<l2≤r2<l3≤r3≤n



2. The concatenation of s[l1..r1], s[l2..r2], s[l3..r3] is
"anniversary".
 
Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤100),
indicating the number of test cases. For each test case:



There's a line containing a string s (1≤|s|≤100) consisting
of lowercase English letters.
 
Output
For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).
 
Sample Input
2
annivddfdersewwefary
nniversarya
 
Sample Output
YES
NO
 
Source
 
Recommend





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h> using namespace std; char str[10001];
struct node
{
int x;
char s;
} q[10010]; int main()
{
int T;
char a[] = "anniversary";
scanf("%d",&T);
while(T--)
{
int flag = 0;
scanf("%s",str);
int l = strlen(str);
int ll = strlen(a);
int num = 0;
for(int j=0; j<l; j++)
{
for(int i=1; i<=ll; i++)
{
if(strncmp(str+j,a+num,i) == 0)
{
int num1 = num + i;
for(int jj=j+i; jj<l; jj++)
{
for(int ii=1; ii<=ll-i; ii++)
{
if(strncmp(str+jj,a+num1,ii) == 0)
{
int num2 = num1 + ii;
for(int jjj=jj+ii; jjj<l; jjj++)
{
if(strncmp(str+jjj,a+num2,ll-num2) == 0)
{
printf("YES\n");
flag = 1;
break;
}
}
}
if(flag == 1)
{
break;
}
}
if(flag == 1)
{
break;
}
}
if(flag == 1)
{
break;
}
}
if(flag == 1)
{
break;
}
}
if(flag == 1)
{
break;
} }
if(flag == 0)
{
printf("NO\n");
}
}
return 0;
}

 

最新文章

  1. 关于Android中的三级缓存
  2. SQLite源程序分析之sqlite3.c
  3. 提升PHP编程效率的20个要素
  4. JS中判断 !=&quot;&quot; 或者 !=null 失效
  5. bzoj3295: [Cqoi2011]动态逆序对(树套树)
  6. ABAP 内表 详解
  7. php数据通信方式
  8. js不能执行,IE处理方法
  9. lambda 3
  10. MVVM模式下 DataTemplate 中控件的绑定
  11. [转]MS Excel VBO option missing in Blue Prism
  12. 对css盒模型的理解
  13. [Swift]LeetCode756. 金字塔转换矩阵 | Pyramid Transition Matrix
  14. IntelliJ IDEA2018.3 最新破解方法
  15. SpringBoot整合Druid数据源
  16. python数据结构之栈
  17. WPF PrismDialog PopupWindowAction使用MetroWindow
  18. 用IntelliJ的IDEA来创建SpringBoot框架
  19. [置顶] 刘汝佳《训练指南》动态规划::Beginner (25题)解题报告汇总
  20. 蜗牛慢慢爬 LeetCode 19. Remove Nth Node From End of List [Difficulty: Medium]

热门文章

  1. vuex的各个细节理解(因人而异)
  2. Android 7.0系统代码调用安装apk时报错FileUriExposedException完美解决
  3. 浅谈es6 promise
  4. C++ Primer(第4版)-学习笔记-第3部分:类和数据抽象
  5. wake states
  6. 洛谷 4768 LOJ 2718「NOI2018」归程
  7. saltstack(五) saltstack的state状态管理
  8. Linux学习总结(18)——Linux使用init命令关机、重启、切换模式
  9. noip模拟赛 兔子
  10. kafka+spark-streaming实时推荐系统性能优化笔记