zhx's contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 3835    Accepted Submission(s): 1255

Problem Description

As one of the most powerful brushes, zhx is required to give his juniors n problems.

zhx thinks the ith problem's difficulty is i. He wants to arrange these problems in a beautiful way.

zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:

1: a1..ai are monotone decreasing or monotone increasing.

2: ai..an are monotone decreasing or monotone increasing.

He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.

zhx knows that the answer may be very huge, and you only need to tell him the answer module p.

Input

Multiply test cases(less than 1000). Seek EOF as the end of the file.

For each case, there are two integers n and p separated by a space in a line. (1≤n,p≤1018)

Output

For each test case, output a single line indicating the answer.

Sample Input

2 233 3 5

Sample Output

2 1

Hint

In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1


# include <iostream>
# include <cstring>
# include <cstdio>
using namespace std;
typedef long long LL;
LL p,mod;LL n;
inline LL quick_mul(LL x,LL y,LL MOD){
x=x%MOD,y=y%MOD;
return ((x*y-(LL)(((long double)x*y+0.5)/MOD)*MOD)%MOD+MOD)%MOD;
}
LL qmod(LL a, LL b)
{
LL ans = 1, pow = a%mod;
while(b)
{
if(b&1) ans = (quick_mul(ans,pow,mod))%mod;
pow = (quick_mul(pow,pow,mod))%mod;
b >>= 1;
}
return ans;
}
int main()
{
while(~scanf("%lld%lld",&n,&p))
{
mod=p;
LL ans=qmod(2,n);
ans=(ans-2+mod)%mod;
printf("%lld\n",ans);
}
return 0;
}

最新文章

  1. Sql Server函数全解&lt;一&gt;字符串函数
  2. BigDecimal使用中的坑
  3. 关于OpenCart的一个小建议
  4. Swift3.0语言教程使用编码创建和初始化字符串
  5. 酷派5890 ROM教程
  6. HDU 1176免费馅饼 DP数塔问题转化
  7. Making raycast ignore multiple layers
  8. 软件工程 speedsnail 冲刺8
  9. [C语言 - 3] 字符串
  10. CSS定位与浮动
  11. COB (Chip On Board) 製程介紹/簡介/注意事項 II
  12. Java读书笔记1
  13. [DP之树形DP]
  14. 关于php内存释放问题 内存溢出问题(二)
  15. Java中的String,StringBuilder,StringBuffer三者的区别(转载)
  16. asp.net mvc 使用NPOI插件导出excel
  17. [LeetCode] Bomb Enemy 炸弹人
  18. 『Python CoolBook』C扩展库_其五_C语言层面Python库之间调用API
  19. java面试技巧
  20. 计算TCP链接的RTO超时重传时间

热门文章

  1. python colormap
  2. WPF入门(1)——DataContext
  3. 有趣的后渗透工具 Koadic
  4. 怎样理解第三方Cookie
  5. [http]HTTP请求过程
  6. 初学java3 条件判断
  7. ubuntu目录结构(转)
  8. LeetCode 腾讯精选50题--子集
  9. SpringCloud多网卡配置(转)
  10. 15.Filter(过滤器)