作者:邓聪聪

  智能以太保护SEP(Smart Ethernet Protection)是一种专用于以太网链路层的环网协议。SEP是一种以太环路保护机制,它通过有选择性地阻塞网络环路冗余链路,来达到消除网络二层环路的目的,避免报文在环路网络中增生和无限循环,有效防止形成网络风暴。本人刚接手了一套网络,布局也不是太复杂,基本全是2层网络,所以就利用了sep这个小技术。

  实例1:

sysname sw1
#
vlan batch to
#
stp disable
#
sep segment
control-vlan
block port optimal
preempt delay
protected-instance to
sep segment
control-vlan
block port optimal
preempt delay
tc-notify segment
protected-instance to
#
interface Vlanif12
ip address 10.1.1.1 255.255.255.224
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type access
port default vlan
#
interface GigabitEthernet0//
shutdown
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan to
stp disable
sep segment edge primary
#
interface GigabitEthernet0//
shutdown
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment 10 edge primary
#
sysname sw2
#
stp disable
#
sep segment
control-vlan
protected-instance to
#

  sep segment 11
  control-vlan 100
  block port optimal
  preempt delay 30
  tc-notify segment 5
  protected-instance 0 to 48

interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment 5

  interface GigabitEthernet0/0/4
  port link-type trunk
  port trunk allow-pass vlan 11 100
  stp disable
  sep segment 11 edge primary

sysname sw3
#
stp disable
#
sep segment
control-vlan
protected-instance to
sep segment
control-vlan
tc-notify segment
protected-instance to
#
interface Vlanif11
ip address 1.1.1.30 255.255.255.224
#
interface Vlanif12
ip address 10.1.1.2 255.255.255.224
#
interface MEth0//
#
interface GigabitEthernet0//
port link-type access
port default vlan
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan to
stp disable
sep segment
sep segment priority
#
interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
sep segment priority
#
sysname sw4
#
vlan batch
#
stp disable
#
sep segment
control-vlan
protected-instance to
#

  sep segment 11
  control-vlan 100
  tc-notify segment 10
  protected-instance 0 to 48

interface Vlanif11
ip address 1.1.1.4 255.255.255.224
#

interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 11 100
 stp disable
 sep segment 11
 sep segment 11 priority 128

interface GigabitEthernet0//
port link-type trunk
undo port trunk allow-pass vlan
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
sysname sw5
#
sep segment
control-vlan
protected-instance to
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port link-type trunk
port trunk allow-pass vlan
stp disable
sep segment
#

  实例2:

9306配置:

sep segment 1
control-vlan 4094
block port optimal
preempt delay 30
tc-notify segment 2
protected-instance 0 to 48
sep segment 2
control-vlan 4094
block port optimal
preempt delay 15
tc-notify segment 1
protected-instance 0 to 48
sep segment 3
control-vlan 4090
block port optimal
preempt delay 15
protected-instance 0 to 48
#
interface Vlanif1
ip address 1.1.1.1 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
shutdown
port hybrid tagged vlan 4094
stp disable
sep segment 1 edge secondary
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 4094
stp disable
sep segment 2 edge primary
#
interface GigabitEthernet0/0/3
port hybrid tagged vlan 4094
stp disable
sep segment 1 edge primary
#
interface GigabitEthernet0/0/4
port hybrid tagged vlan 4090
stp disable
sep segment 3 edge primary
#
interface GigabitEthernet0/0/5
port hybrid tagged vlan 4090
stp disable
sep segment 3 edge secondary
#

 

分支1-5700配置:

sep segment
control-vlan
block port optimal
protected-instance to #
interface Vlanif1
ip address 1.1.1.254 255.255.255.0
#
interface MEth0//
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#

分支3-5700配置:

sep segment 1
control-vlan 4094
tc-notify segment 2
protected-instance 0 to 48
sep segment 2
control-vlan 4094
tc-notify segment 1
protected-instance 0 to 48
#
interface Vlanif1
ip address 1.1.1.2 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 4094
stp disable
sep segment 2 edge secondary
#
interface GigabitEthernet0/0/2
port hybrid tagged vlan 4094
stp disable
sep segment 1
sep segment 1 priority 128
#
interface GigabitEthernet0/0/3
port hybrid tagged vlan 4094
stp disable
sep segment 1
#

分支2-5700配置:

sep segment 2
control-vlan 4094
protected-instance 0 to 48
#
interface Vlanif1
ip address 1.1.1.3 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port hybrid tagged vlan 4094
stp disable
sep segment 2
sep segment 2 priority 128
#
interface GigabitEthernet0/0/2
shutdown
port hybrid tagged vlan 4094
stp disable
sep segment 2

分支1配置:

sep segment
control-vlan
protected-instance to
#
interface Vlanif1
#
interface MEth0//
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
#

分支2配置:

sep segment
control-vlan
protected-instance to
#
interface Vlanif1
ip address 1.1.1.6 255.255.255.0
#
interface MEth0//
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment
sep segment priority
#
interface GigabitEthernet0//
port hybrid tagged vlan
stp disable
sep segment

最新文章

  1. ThinkPHP去掉URL中的index.php
  2. LeetCode Shortest Palindrome
  3. js正则--验证6-12位至少包含数字、小写字母和大些字母中至少两种字符,
  4. 图像JPEG格式介绍
  5. UVa401 回文词
  6. Java开发之Java对数组的复制
  7. 学习CSS了解单位em和px的区别
  8. [刷题]算法竞赛入门经典(第2版) 6-9/UVa127 - "Accordian" Patience
  9. JQuery之事件冒泡
  10. nginx+tomcat单个域名及多个域名配置
  11. Linux中docker的使用
  12. Install MariaDB on Ubuntu server
  13. [转] iOS开发工具——网络封包分析工具Charles
  14. No service of type Factory<LoggingManagerInternal> available in ProjectScopeService
  15. [Network] okhttp3与旧版本okhttp的区别分析
  16. getchar()、putchar()、gets()、puts()、cin.get()、cin.getline()、getline()
  17. Unity核心对象模型
  18. linux ip白名单、防火墙白名单 设置
  19. 使用nagios检测windows服务器
  20. 详解Oracle数据货场中三种优化:分区、维度和物化视图

热门文章

  1. Linux记录-安装LAMP和R环境
  2. Maccms8.x 命令执行漏洞分析
  3. 067、如何部署Calico网络 (2019-04-10 周三)
  4. SQL Server进阶(四):联接-cross join、inner join、left join、right jion、union、union all
  5. request.setCharacterEncoding()、response.setCharacterEncoding()的区别
  6. NSScanner类的基本用法
  7. jsp快速开始
  8. solr window环境安装配置和管理页面基本使用
  9. webpack 配置全局 jQuery 对象
  10. call 和 apply 的区别