Genealogical tree

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7285   Accepted: 4704   Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

Ural State University Internal Contest October'2000 Junior Session

题意:有n个人,编号1~n,然后输入n行,第i行有一些编号,这些编号代表第i个人的后代,每行输入以0结束。然后按照辈分输出这些编号

题并不难,拓扑排序的模板题,但是输出格式有点坑

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <string>
#define ll long long
#define ms(a) memset(a,0,sizeof(a))
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
const double E=exp(1);
const int maxn=1e3+10;
using namespace std;
int a[maxn][maxn];
int vis[maxn];
int n;
void toposort()
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(vis[j]==0)
{
vis[j]--;
cout<<j;
for(int k=1;k<=n;k++)
{
if(a[j][k]==1)
{
a[j][k]--;
vis[k]--;
}
}
if(i!=n)
cout<<" ";
break;
} }
if(i==n)
cout<<endl;
}
}
int main(int argc, char const *argv[])
{
cin>>n;
ms(a);
ms(vis);
int x;
for(int i=1;i<=n;i++)
{
for(int j=1;;j++)
{
scanf("%d",&x);
if(x==0)
break;
a[i][x]=1;
vis[x]++;
}
}
toposort();
return 0;
}

最新文章

  1. 解决使用IE8打开ADFS 3.0登录页面
  2. &quot;Type Coercion failed&quot; Error in FlashBuilder 4.7
  3. CSS易混淆知识点总结与分享-定位与布局
  4. Android学习笔记之Drawable 文件夹
  5. 省选加油&gt;_&lt;
  6. Form表单学习网站
  7. vs调试 本地IIS
  8. iOS开发 - CocoaPods安装和使用教程
  9. Java中线程的使用 (2)-多线程、线程优先级、线程睡眠、让步、阻塞
  10. 【.net 深呼吸】实时获取计算结果
  11. JavaScript中DOM
  12. Java爬虫_资源网站爬取实战
  13. 项目Beta冲刺第二天
  14. [bzoj4625][BeiJing2016]水晶
  15. grep、awk、sed的巩固练习
  16. [android] 短信的广播接收者
  17. linux的shadow文件
  18. Linux下常用工具
  19. 关系型数据库性能测试参考指标----SQL Server
  20. Scrapy-redis实现分布式爬取的过程与原理

热门文章

  1. RPC 服务器不可用
  2. 工程优化暨babel升级小记
  3. Android之侧滑菜单DrawerLayout的使用
  4. 『OpenCV3』Harris角点特征_API调用及python手动实现
  5. OAF 交互式列车 上一步 下一步的简单使用
  6. Error Code: 1175. You are using safe update mode and you tried to ......
  7. IOS UI-滚动视图(UIScrollView)
  8. linux create a process
  9. 51nod算法马拉松28-a
  10. git push时候总提示输入账号密码,如何免除设置?