Channel Allocation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 13173   Accepted: 6737

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere
with one another. This condition is satisfied if adjacent repeaters use different channels. 



Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of
channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example,
ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 



Following the number of repeaters is a list of adjacency relationships. Each line has the form: 



A:BCDH 



which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line
has the form 



A: 



The repeaters are listed in alphabetical order. 



Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when
only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed.




     题意:平面内最多26个点,给出一些点与点之间的矛盾关系。问最少使用多少颜

色才干给这些点染色,并保证矛盾点之间不同色。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<vector> using namespace std; int n;
int v[30];
char str[31];
int minn;
vector<int>q[30]; int up(int x,int k)
{
for(int i=0;i<q[x].size();i++)
{
if(v[q[x][i]] == k)
{
return -1;
}
}
return 1;
} void DFS(int m,int num)
{
if(m == n)
{
minn = min(minn,num);
return ;
}
for(int i=0;i<num;i++)
{
v[m] = i;
if(up(m,i) == 1)
{
DFS(m+1,num);
}
}
v[m] = num;
DFS(m+1,num+1);
v[m] = -1;
} int main()
{
while(scanf("%d",&n)!=EOF)
{
if(n == 0)
{
break;
}
minn = 999999;
for(int i=0;i<=30;i++)
{
q[i].clear();
}
for(int i=0;i<n;i++)
{
scanf("%s",str);
for(int j=2;str[j]!='\0';j++)
{
q[(str[0]-'A')].push_back(str[j]-'A');
}
}
for(int i=0;i<30;i++)
{
v[i] = -1;
}
DFS(0,0);
if(minn == 1)
{
printf("1 channel needed.\n");
}
else
{
printf("%d channels needed.\n",minn);
}
}
return 0;
}

最新文章

  1. Python 操作 MS Excel 文件
  2. Java 应该跨四个平台
  3. 【温故而知新-Javascript】使用拖放
  4. bzoj 1012 维护一个单调数列
  5. C# 编写Windows Service(windows服务程序)【转载】
  6. springMVC+JAP整合彻底摆脱persistence.xml配置文件
  7. 常见的排序算法之Java代码解释
  8. POJ Stockbroker Grapevine 1125 多源最短路(Floyd)
  9. JavaScript之JSON
  10. TROUBLE SHOOTING: FRM-30425
  11. UNIX环境高级编程——线程属性
  12. layedit第三次改造
  13. Eclipse设置所有新创建文件默认格式为UTF-8
  14. Windows Server 2016-配置Windows Defender防病毒排除项
  15. 《Head First设计模式》批注系列(一)——观察者设计模式
  16. C++面向对象高级编程(九)Reference与重载operator new和operator delete
  17. cocos2d::CCFileUtils::sharedFileUtils()-&gt;getFileData(szFile, &quot;r&quot;, &amp;bufferSize) 不同平台返回值不一样
  18. 《Cocos2d-x游戏开发实战精解》学习笔记1--在Cocos2d中显示图像
  19. C++解析(23):多态与C++对象模型
  20. SUN巡检命令

热门文章

  1. 对IIC总线时序的一点理解以及ACK和NACK(NAK)
  2. hive中简单介绍分区表(partition table)——动态分区(dynamic partition)、静态分区(static partition)
  3. 安装了XAMPP,PHP怎么显示中文
  4. percona-xtrabackup系列一:简单使用
  5. 【Linux】eclipse juno 边框过大的调整方法
  6. mybatis 于 hibernate区别
  7. mysql字符生命周期
  8. 《Java设计模式》之模板方法模式
  9. SITEMAP放到独立的文件上面
  10. 关于UDP-读这篇就够了(疑难杂症和使用)