Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3145   Accepted: 1591

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then,
the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared
the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, thejth value on
the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i.
The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead
of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least
0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2
概率dp。
题意 : 足球淘汰赛。一共同拥有n轮,共同拥有2^n支队伍參赛,所以总共进行n轮比赛就可以决出冠军。设dp[i][j]为第i轮比赛中j队胜出的概率。则dp[i][j]=dp[i-1][j]*dp[i-1][k]*p[j][k].k为在本轮j的对手。
然后以下的问题是怎样求出k。能够列出在2进制状态下的比赛过程。然后能够发现规律:j>>i-1^1==k>>i-1;
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;
#define ll long long
double dp[8][130],p[130][130];
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n!=-1)
{
int num=1<<n;
memset(dp,0,sizeof(dp));
for(int i=0;i<num;i++)
{
for(int j=0;j<num;j++)
scanf("%lf",&p[i][j]);
dp[0][i]=1;
}
for(int i=1;i<=n;i++)
for(int j=0;j<num;j++)
for(int k=0;k<num;k++)
{
if((j>>(i-1)^1)==(k>>i-1))
dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
}
int ans;double Max=-1;
for(int i=0;i<num;i++)
{
if(dp[n][i]>Max)
{
ans=i+1;
Max=dp[n][i];
}
}
printf("%d\n",ans);
}
return 0;
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

最新文章

  1. Placeholder在IE8的兼容问题
  2. 一鼓作气 博客--第五篇 note5
  3. Bean不同配置方式的比较
  4. fiddler实现手机端抓包(代理)
  5. ant 使用指南---java模块化编译【转】
  6. C#之 HashSet(临时笔记,未参考资料,请慎重)
  7. Altium查看所有快捷键,图文教程
  8. 安全:加固你的ssh 登录
  9. python 小技巧 防止SSL报错信息
  10. hadoop大事件
  11. 浅析Python多线程
  12. [PA2014]Kuglarz
  13. Linux记录-TCP状态以及(TIME_WAIT/CLOSE_WAIT)分析(转载)
  14. myeclipse修改了安装目录名字打不开解决方法
  15. java如何从一段html代码中获取图片的src路径
  16. SSH基本管理和配置文件的使用
  17. Social Media Addiction【社交媒体上瘾】
  18. 打包python脚本为exe
  19. python 获取代码宿主机名 ip
  20. noip模拟赛 游

热门文章

  1. Visual Studio Team Services使用教程--Readers tfs组成员添加
  2. iOS UISearchDisplayController学习笔记
  3. 【C++ Primer每天刷牙】一间 迭代器
  4. Oracle 数据恢复指导具体解释
  5. Oracle中的delete和truncate的关系
  6. ubunut 查看port被哪个程序占用
  7. ios swift学习日记1-Swift 初见
  8. 讨厌OpenSSL
  9. Thinking in UML 学习笔记(四)——UML活动图来看核心
  10. 第23章 访问者模式(Visitor Pattern)