1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

#include"iostream"
#include "algorithm"
#include <sstream>
#include"string.h"
#include "vector"
using namespace std;

bool mycompare(string s1,string s2)
{
return s1+s2<s2+s1;
}

int main()
{
int n;
cin >> n;
vector<string> num;
string str;
for(int i=0;i<n;i++)
{
cin >> str;
num.push_back(str);
}
sort(num.begin(),num.end(),mycompare);
string strs;
for(int i=0;i<n;i++)
strs += num[i];
int non_zero = -1;
for(int i=0;i<strs.size();i++)
{
if(strs[i]!='0')
{
non_zero = i;
break;
}

}
if(non_zero == -1)
cout <<"0"<<endl;
else
{
strs = strs.substr(non_zero);
cout<<strs<<endl;
}

return 0;
}

最新文章

  1. SQL基础之数据库
  2. 【CCCC天梯赛决赛】
  3. Android v4、v7、v13 的区别
  4. iphone dev 入门实例5:Get the User Location &amp; Address in iPhone App
  5. java io流缓冲理解
  6. 二分图的最大匹配-hdu-3729-I&#39;m Telling the Truth
  7. jquery使用load开展局部刷新没有效果
  8. loadrunner 添加集合点和添加压力机
  9. 定义一个Map集合,key和value不规定类型,任意放入数据,用keySet()和 entrySet()两种方式遍历出Map集合的数据
  10. 使用ORM进行前后端数据交互
  11. HDU2844买表——多重背包初探
  12. Async和await关键字的用法
  13. c++ 11和java 8都支持lambda表达式
  14. Flask初级(六)flash模板渲染
  15. python3.6 ubuntu
  16. VC字符串处理整理
  17. Suricata开源IDS安装与配置
  18. mybatis 需要注意的点 MyBatis 插入空值时,需要指定JdbcType (201
  19. PHP用imageTtfText函数在图片上写入汉字
  20. android httpclient 设置超时

热门文章

  1. .NET 微信开放平台接口(接收短信、发送短信)
  2. c语言:将二进制数按位输出
  3. 记一次bug查找经历
  4. sqlserver 注释提取工具
  5. JavaScript –type
  6. java版微信公众平台自定义菜单创建代码实现
  7. JSP实现页面跳转的方式
  8. android电源“有毒”移动电源Android版的设计及其实现
  9. php提供service总结---wsdl篇
  10. JS —— 数组与字符串方法