1088. Rational Arithmetic (20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf 思路 分数的四则运算,难点主要是在输出数据的格式化(参见代码stringFormat函数)上,比较考验耐心和逻辑,仔细就行。 代码
#include<iostream>
using namespace std;
typedef long long ll; ll a,b,c,d,gcdvalue; ll gcd(ll a,ll b)
{
return b == 0?abs(a):gcd(b,a % b);
} string stringFormat(ll a,ll b)
{
string res = "";
gcdvalue = gcd(a,b);
a /= gcdvalue;
b /= gcdvalue;
if(a * b < 0)
res += "(-";
ll c = abs(a), d = abs(b);
if(c/d == 0)
{
if( c % d == 0)
res += "0";
else
res += to_string(c) + "/" +to_string(d);
}
else
{
res += to_string(c/d);
if(c % d != 0)
{
res += " " + to_string(c % d) + "/" +to_string(d);
}
}
if(a * b < 0)
res += ")";
return res;
} int main()
{
scanf("%lld/%lld %lld/%lld",&a,&b,&c,&d);
ll sum1,sum2,sub1,sub2,mul1,mul2,div1,div2;
//sum
sum1 = a * d + b * c;
sum2 = b * d;
sub1 = a * d - b * c;
sub2 = b * d;
mul1 = a * c;
mul2 = b * d;
div1 = a * d;
div2 = b * c;
string a1 = stringFormat(a,b);
string a2 = stringFormat(c,d);
cout << a1 << " + " << a2 <<" = " << stringFormat(sum1,sum2) << endl;
cout << a1 << " - " << a2 <<" = " << stringFormat(sub1,sub2) << endl;
cout << a1 << " * " << a2 <<" = " << stringFormat(mul1,mul2) << endl;
if(a2 != "0")
cout << a1 << " / " << a2 <<" = " << stringFormat(div1,div2) << endl;
else
cout << a1 << " / " << a2 <<" = " << "Inf" << endl;
}

  

最新文章

  1. mysql timeout connection
  2. Nodejs进阶:如何玩转子进程(child_process)
  3. 【转】win8.1下安装ubuntu
  4. C# web winform 路径
  5. Linux内核源码分析方法
  6. 锋利的jQuery之事件
  7. ASP.NET WEB API 初探
  8. VARCHAR2转换为CLOB碰到ORA-22858错误
  9. css 权威指南笔记( 五)结构和层叠
  10. mysql登录报错 ERROR 1045 (28000)
  11. golang RWMutex读写锁分析
  12. 基于puppeteer模拟登录抓取页面
  13. hive创建orc表,使用LLAP查询
  14. 【源码阅读】Mimikatz相关资料
  15. Windows Server 2012设置WinDbg Kernel Debugging Local
  16. python学习笔记2-字符串操作
  17. No.15 selenium for python JavaScript
  18. 梯度下降、随机梯度下降、方差减小的梯度下降(matlab实现)
  19. centos6.5挂载windows共享的文件夹
  20. C++开源库集合

热门文章

  1. 《java入门第一季》之面向对象(包概述)
  2. LeetCode之“链表”:Sort List
  3. PS图层混合算法之一(不透明度,正片叠底,颜色加深,颜色减淡)
  4. Linux常用命令(第二版) --文件管理命令
  5. Erlang cowboy http request生命周期
  6. Global Financial Applications uses the following Public tables
  7. 那些年Android开发中遇到的坑
  8. UNIX/Linux C 程序员需要掌握的七种武器
  9. The 13th tip of DB Query Analyzer, powerful processing EXCEL file
  10. rails中weill_paginate的paginate方法中不能使用额外参数的解决办法