算法:搜索

题意:相邻的两个数之和是素数,别忘了最后一个,和第一个

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.



Note: the number of first circle should always be 1.









Input

n (0 < n < 20).





Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.



You are to write a program that completes above process.



Print a blank line after each case.





Sample Input

6

8





Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4



Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

代码:

#include <iostream>
#include <string>
#include <algorithm>
#include <iomanip>
#include <cstring>
using namespace std;
int a[30],b[45],n,m,c[30];
void cmp()
{ memset(b,1,sizeof(b));
b[1]=b[0]=0;
for(int i=2;i<=22;i++)
{
for(int j=2*i;j<45;j=j+i)
b[j]=0;
}
}
void dfs(int x,int k)
{
if(k==n&&b[c[0]+c[n-1]])
{
for(int i=0;i<n;i++)
{
if(i)cout<<" ";
cout<<c[i];
}
cout<<endl;
}
else
{
for(int i=2;i<=n;i++)
{
if(!a[i]&&b[i+c[k-1]])
{
a[i]=1;
c[k]=i;
dfs(n,k+1);
a[i]=0;
}
}
}
}
int main()
{
int i,j=0;
cmp();
while(cin>>n)
{
for(i=1;i<=n;i++)
a[i]=0;
c[0]=1;
cout<<"Case "<<++j<<":"<<endl;
dfs(n,1);
cout<<endl;
}
return 0;
}

最新文章

  1. 各种开源Android 系统定制
  2. 问题(the question)
  3. iOS YSMine 通用设置
  4. Python基础(9)--正则表达式
  5. 在Mac上配置Android adb命令
  6. Hive history date mapping
  7. oracle数据库什么情况下创建索引比较好
  8. elasticsearch配置文件解析
  9. Solr In Action 笔记(1) 之 Key Solr Concepts
  10. RH133读书 笔记(3) - Lab 3 Configuring the kernel
  11. 纯JS写最简单的图片轮播
  12. EXCEL数据导入数据库实例(NPOI)
  13. Python求解啤酒问题(携程2016笔试题)
  14. 爬虫之proxy(代理)
  15. Android短信过滤项目中的观察者模式
  16. html 自定义上传图片样式,并回显
  17. docker swarm英文文档学习-12-在集群模式中的Raft共识
  18. node代码打包为 exe文件---端口进程关闭demo
  19. [原创]K8 MSF Bind Shell TCP 连接工具
  20. python 爬取全量百度POI

热门文章

  1. TCP的长连接与短连接
  2. 兼容IE与firefox、chrome的css 线性渐变(linear-gradient)
  3. Android-4
  4. Spring MVC使用@ResponseBody返回JSON数据406以及乱码问题解决方案
  5. Qt C++中的关键字explicit——防止隐式转换(也就是Java里的装箱),必须写清楚
  6. Mysql unix_timestamp() FROM_UNIXTIME和DATE_FORMAT(date,format)
  7. 【转】Linux內核驅動之GPIO子系統(一)GPIO的使用 _蝸牛
  8. [VBA]发布一个计算桩号之差的Excel自定义函数(VBA)
  9. .NET中 DAL+IDAL+Model+BLL+Web是什么意思
  10. hdu5014:number sequence对称思想