Problem Description
给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 
Input
第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,

第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x
1, y
1, x
2, y
2 (1 ≤ k ≤ 10, 1 ≤ x
1, x
2 ≤ n, 1 ≤ y
1, y
2 ≤ m),其中k表示gloria最多能转的弯数,(x
1, y
1), (x
2, y
2)表示两个位置,其中x
1,x
2对应列,y
1, y
2对应行。

 
Output
每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 
Sample Input
2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3
 
Sample Output
no
yes
 
解题思路:利用最短路径思想,从终点出发,把每个点到终点的最小转折数算出来。
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
typedef struct nod
{
int direct,turn,x,y;
friend bool operator <(nod n1,nod n2)
{
return n2.turn<n1.turn;
}
}node;
int h,w,sx,sy,dx,dy,maxturn,flog;
int N[105][105];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char map[105][105]; void BFS()
{
int e,tx,ty;
priority_queue<node>Q;
node q,p;
q.x=dx-1;q.y=dy-1;q.direct=-1;q.turn=0;
Q.push(q);N[dy-1][dx-1]=0;
while(!Q.empty())
{
q=Q.top();
Q.pop();
if(q.turn>maxturn)
continue;
for(e=0;e<4;e++)
{
tx=q.x+dir[e][0];ty=q.y+dir[e][1];
if(tx>=0&&tx<w&&ty>=0&&ty<h&&map[ty][tx]!='*')
{
p.direct=e; p.x=tx; p.y=ty; p.turn=q.turn;
if(q.direct>=0&&q.direct!=e)
p.turn++;
if(N[ty][tx]>=p.turn)
{
N[ty][tx]=p.turn;
Q.push(p);//printf("%d %d\n",q.turn,e);
}
}
}
}
if(N[sy-1][sx-1]<=maxturn)
flog=1;
}
int main()
{
int t,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&h,&w);
getchar();
for(i=0;i<h;i++)
{
for(j=0;j<w;j++)
{
scanf("%c",&map[i][j]);
N[i][j]=10000000;
}
getchar();
}
scanf("%d%d%d%d%d",&maxturn,&sx,&sy,&dx,&dy);
flog=0;
BFS(); printf("%s\n",flog?"yes":"no");
}
}

 

最新文章

  1. ubuntu系统升级记录
  2. JiaThis分享插件的使用
  3. Bootstrap系列 -- 7. 列表排版方式
  4. Win2008上.NET4.0部署出错HTTP 错误 500.21 - Internal Server Error的解决方法
  5. Java观察者设计模式
  6. __FILE__,__LINE__,FUNCTION__
  7. Sql Server 2005 开发版亲測可用下载地址
  8. mysql存储过程中使用临时表和游标
  9. docker 保存更改的镜像:
  10. 高仿淘宝送货地址暴走漫画系列(附demo)
  11. openstack controller ha测试环境搭建记录(五)——配置rabbitmq集群
  12. SQLalchemy模块用法
  13. tomcat中Servlet的工作机制
  14. 一、.NetCore EF 之命令行
  15. 如何实现一个基于 jupyter 的 microservices
  16. php安全配置记录和常见错误梳理
  17. python解析VOC的xml文件并转成自己需要的txt格式
  18. 题目1076:N的阶乘(大数乘法)
  19. MAX II Device Compatibility with 5.0-V CMOS Devices
  20. PhoneGap3.2安装步骤

热门文章

  1. SQL Server 阻塞排除的 2 方法
  2. Inno Setup 精灵显示插件 InnoFairy (V2.0 版本)
  3. javascript链式调用实现方式总结
  4. Boost库学习之旅入门篇
  5. MFC子窗口和父窗口(SetParent,SetOwner)
  6. EasyUI两种动态添加tab Iframe页面的方法
  7. 线性表之顺序表(C语言实现)
  8. NYOJ 46-最少乘法次数(数论)
  9. A Game with Colored Balls
  10. POJ 3468 A Simple Problem with Integers(线段树区间求和)