Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:

    1.       input n

    2.       print n

    3.       if n = 1 then STOP

    4.               if n is odd then   n <-- 3n+1

    5.               else   n <-- n/2

    6.       GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10

100 200

201 210

900 1000

Sample Output

1 10 20

100 200 125

201 210 89

900 1000 174

#include <stdio.h>
#include <stdlib.h>
int arr[1000010];
int suan(int x,int num){
if(x==1)
return num+1;
if(x%2==0)
suan(x/2,num+1);
else
suan(3*x+1,num+1);
}
int main(){
int m,n;
while(scanf("%d %d",&n,&m)==2){
int i;
bool First=true;
int maxx=0;
if(n>m){
n=n+m;
m=n-m;
n=n-m;
First=false;
} for(i=n;i<=m;i++){
arr[i]=suan(i,0);
if(maxx<arr[i])
maxx=arr[i];
}
if(First)
printf("%d %d %d\n",n,m,maxx);
else{
printf("%d %d %d\n",m,n,maxx);
}
}
return 0;
}

最新文章

  1. IT领域中哲学原理的应用——个体与整体
  2. MVVM架构~knockoutjs系列之为Ajax传递Ko数组对象
  3. WebRequest 获取网页乱码
  4. 剑指offer题目21-30
  5. protobuf序列化、反序列化
  6. Git学习(2)Git 安装
  7. Ajax的“dataType”乱用的陷阱
  8. c++,C# 转换
  9. LVS集群的体系结构
  10. CI Weekly #11 | 微服务场景下的自动化测试与持续部署
  11. dedecms中arclist标签做分页以及分页点击模块样式错乱问题
  12. sitecore开发入门教程如何获取Sitecore项目的域名
  13. Visio 画图
  14. 使用Java Api 操作HDFS
  15. ICCV2013、CVPR2013、ECCV2013目标检测相关论文
  16. vs2013c#测试using System; using System.Collections.Generic; using System.Linq; using System.Text; using System.Threading.Tasks; namespace ConsoleApplication1_CXY { class Program { stati
  17. 一点ExtJS开发的感悟
  18. sql 字符串函数、数学函数
  19. 20145227鄢曼君《网络对抗》逆向及Bof基础
  20. c++之初级的消息队列及线程池模型

热门文章

  1. C#设置与获取目录权限(.net控制ACL)
  2. 新浪微博failed to receive access token
  3. javascript创建对象(一)
  4. cas系列(三)--HTTP和HTTPS、SSL
  5. Linux使用fdisk进行磁盘管理
  6. ios专题 - socket(1)
  7. Linux VPS使用百度网盘API上传备份文件
  8. 分享一个在PearOS里面的plank的配置文件
  9. nodejs框架express4.x 学习--安装篇
  10. HTML网页图片滚动代码