题目

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2

5

1234567890001 95

1234567890005 100

1234567890003 95

1234567890002 77

1234567890004 85

4

1234567890013 65

1234567890011 25

1234567890014 100

1234567890012 85

Sample Output:

9

1234567890005 1 1 1

1234567890014 1 2 1

1234567890001 3 1 2

1234567890003 3 1 2

1234567890004 5 1 4

1234567890012 5 2 2

1234567890002 7 1 5

1234567890013 8 2 3

1234567890011 9 2 4

题目解读

这题看的我真费劲,英语硬伤啊,不过看懂题目之后发现这题一点都不难啊,大概意思是说:给出n个考场,给出每个考场内的考生数目m、考生的编号、分数,让最终输出考生的最终排名,输出格式是:编号 总排名 考场号 考场内排名,要求排名是按照分数从高到底到底,如果分数一样就并列,但是要学号小的在前。

注意点:

  1. 学生编号是 13 位数字,最后输出也一定要是13位,不足13位补前导0。
  2. 假如 a b 分数相同,之后是 c d分数相同,排名是 1 1 3 3,而不是 1 1 2 2,也就是说,第二个人他把那个位置占了,但是排名要和他前面那个人保持一致。

思路分析

  • 构建按结构体 Student 存储考试信息:因为编号是13位数字,所以不能用int,可以用 long long 或者 char[] 或者 string,但因为编号也要用于排序,字符串数组排序需要逐个比较字符,速度较慢,所以我们直接用 long long 存储了,直接比大小
  • vector<Student> total_stu 保存全部学生信息,用 vector<Student> local_stu 保存考场内学生信息。
  • 考场号按顺序编号 1-N,没读入一个考场的学生信息,就先按分数排名,得到考场内排名 stu[i].local_rank,注意分数相同排名相同,然后将其移入 total_stu。
  • 多个考场考生信息全部统计完后,对 total_stu 进行排序,得到 每个考生的最终排名,同样需要调整分数相同排名相同。
  • 最后,输出考生数目(total_stu.size()),输出每个考生信息。

满分代码

注意输出编号一定要是 printf("%013lld", stu[i].no),不然你最后一个用例过不了。

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
// 考生信息
struct Student {
// 编号 13位数字
// string no; // 字符串排名需要逐个比较字符,速度慢,这里用空间换时间
long long no;
// 分数 最终排名 考场号 考场内排名
int score, final_rank, local_number, local_rank;
}; // 按分数降序
bool cmp(Student a, Student b) {
return a.score != b.score ? a.score > b.score : a.no < b.no;
} int main() { // N个考场,考场内M个考生
int n, m;
cin >> n;
// 保存全部考生信息
vector<Student> total_stu;
for (int i = 1; i <= n; ++i) {
// 当前考场 m 人
cin >> m;
// 保存当前考场考生信息
vector<Student> local_stu(m);
for (int j = 0; j < m; ++j) {
// 学号和分数
cin >> local_stu[j].no >> local_stu[j].score;
// 当前考场号
local_stu[j].local_number = i;
}
// 考场内按分数排名
sort(local_stu.begin(), local_stu.end(), cmp);
// 设置考场内排名,成绩相同排名应该一样,
// 再将当前考场内考生信息加入全部信息集合
local_stu[0].local_rank = 1;
total_stu.push_back(local_stu[0]);
for (int j = 1; j < m; ++j) {
// 并列
if (local_stu[j].score == local_stu[j - 1].score)
local_stu[j].local_rank = local_stu[j - 1].local_rank;
// 注意这里是 j + 1,不是 local_stu[j - 1].local_rank + 1
// 因为排名是 1 1 3 4 4 6 这样的规则
else
local_stu[j].local_rank = j + 1;
// 将他加入全部信息的集合
total_stu.push_back(local_stu[j]);
}
}
// 再对全部学生按成绩降序排名,得到考生的最终排名
sort(total_stu.begin(), total_stu.end(), cmp);
// 设置最终排名
total_stu[0].final_rank = 1;
for (int j = 1; j < total_stu.size(); ++j) {
// 并列
if (total_stu[j].score == total_stu[j - 1].score)
total_stu[j].final_rank = total_stu[j - 1].final_rank;
else
total_stu[j].final_rank = j + 1;
} // 输出全部考生数目
cout << total_stu.size() << endl;
// 输出每个考生的 编号 总排名 考场号 考场内排名
// 注意编号要13位输出
for(int i = 0; i < total_stu.size(); i++)
printf("%013lld %d %d %d\n", total_stu[i].no, total_stu[i].final_rank, total_stu[i].local_number, total_stu[i].local_rank); return 0;
}

最新文章

  1. PHP与MYSQL事务处理
  2. HDU1086You can Solve a Geometry Problem too(判断线段相交)
  3. C/C++ 结构体 数组 函数传递
  4. CSS实现垂直居中的4种思路
  5. Incorrect integer value: &#39;&#39; for column &#39;id&#39; at row 1
  6. stream转byte数组几种方式
  7. 解决如何让AsyncTask终止操作
  8. [置顶] Android学习系列-Android中解析xml(7)
  9. PHP 中 AJAX 中文乱码解决
  10. src 和 href 的区别
  11. malloc,free简单的实现
  12. W: http://archive.ubuntukylin.com:10006/ubuntukylin/dists/xenial/InRelease: Signature by key 6CE35A4EBAB676094476BE7CD259B7555E1D3C58 uses weak digest algorithm (SHA1)
  13. [USACO 3.3.1]骑马修栅栏t
  14. 聊聊Python的time模块
  15. [转]Oh My Zsh,安装,主题配置
  16. 网络篇:linux下select、poll、epoll之间的区别总结
  17. #WEB安全基础 : HTTP协议 | 0x1 TCP/IP通信
  18. go语言异常处理
  19. Linux下批处理文件编写
  20. C#通过rdp账密直接打开远程桌面

热门文章

  1. 8. input限制手机输入
  2. Java中基础类基础方法(学生类)(手机类)
  3. spring boot连接linux服务器上的redis
  4. Mac安装多版本JDK
  5. python学习笔记(一)---字符串与列表
  6. 前端基础-HTML(2)
  7. thinkphp--多表查询
  8. 设置共享内存大小 【windows】
  9. Inno setup: check for new updates
  10. 矩阵类的代码(C++)