​   For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N, we call N a generator of M.

​   For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256. Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

​   You are to write a program to find the smallest generator of the given integer.

Input

​   Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N, 1 ≤ N ≤ 100, 000.

Output

​   Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print ‘0’.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

HINT

​   题目的意思很明显,要求满足256 (= 245 + 2 + 4 + 5)形式的整数。一个n位整数假设每一位都是9,那么要求的数里面可能的最小的数就是N-9*n;(其中N是给定的数字)。

Accepted

#include<stdio.h>

int min(int t)			//求出给定数字的位数
{ //也可以用循环来求出
if(t<10)return 1;
if(t<100)return 2;
if(t<1000)return 3;
if(t<10000)return 4;
if(t<100000)return 5;
if(t<1000000)return 6;
} int mm(int t) //求出每一位数字的和
{
int k=0;
while(t)
{
k+=t%10;
t/=10;
}
return k;
} int main()
{
int sum;
scanf("%d",&sum);
while(sum--)
{
int flag=0;
int t;
scanf("%d",&t);
int k=min(t);
int minst=t-k*9;
minst=minst>0?minst:1;
for(minst;minst<t;minst++)
{
if((minst+mm(minst))==t)
{
printf("%d\n",minst);
continue;
}
}
printf("0\n"); }
}

最新文章

  1. devexpress treelist 过滤
  2. Mysql大范围分页优化案例
  3. [Java]Hessian客户端和服务端代码例子
  4. Oracle数据库对象题库
  5. JSONP跨域请求数据报错 “Unexpected token :”的解决办法
  6. ScrollView和ListView的冲突问题
  7. IOS UIwebview 背景色调整
  8. Piggy-Bank (完全背包)
  9. Android KitKat 4.4 Wifi移植AP模式和网络共享的调试日志
  10. 2C 产品的本质是人性,2B 产品的背后是业务(转)
  11. UVA-10954 贪心+优先队列
  12. js实现搜索记录列表
  13. cxf webservice请求https
  14. 深入解析Java反射-invoke方法
  15. Elasticsearch.net项目实战
  16. 将本地 项目文件托管到 github
  17. 开发者用的linux系统推荐
  18. ASP.NET AJAX入门系列(1):概述
  19. PDO添加数据的预处理语句
  20. BZOJ 1003: [ZJOI2006]物流运输(spfa+dp)

热门文章

  1. 生产者和消费者问题(synchronized、Lock)
  2. 力扣832. 翻转图像-C语言实现-简单题
  3. 微信小程序引入ECharts组件
  4. Java基础语法:JavaDoc
  5. BurpSuite生成快捷方式
  6. python分离不同后缀名的文件
  7. 测试工程师Docker基础
  8. vue离开页面销毁滚动事件
  9. MyBatis(八):MyBatis插件机制详解
  10. 局部莫兰指数的计算(运用ArcMap)