题意翻译

人们常用的电子表格软件(比如: Excel)采用如下所述的坐标系统:
第一列被标为A,第二列为B,以此类推,第26列为Z。接下来为由两个字母构成的列号: 第27列为AA,第28列为AB…在标为ZZ的列之后则由三个字母构成列号,如此类推。
行号为从1开始的整数。
单元格的坐标由列号和行号连接而成。比如,BC23表示位于第55列23行的单元格。
有时也会采用被称为RXCY的坐标系统,其中X与Y为整数,坐标(X,Y)直接描述了对应单元格的位置。比如,R23C55即为前面所述的单元格。
您的任务是编写一个程序,将所给的单元格坐标转换为另一种坐标系统下面的形式。

输入

第一行一个整数n(1<=n<=10^5),表示将会输入的坐标的数量。
接下来n行,每行一个坐标。
注意: 每个坐标都是正确的。此外不会出现行号或列号大于10^6的单元格。

输出

n行,每行一个被转换的坐标。

题目描述

In the popular spreadsheets systems (for example, in Excel) the following numeration of columns is used. The first column has number A, the second — number B, etc. till column 26 that is marked by Z. Then there are two-letter numbers: column 27 has number AA, 28 — AB, column 52 is marked by AZ. After ZZ there follow three-letter numbers, etc.
The rows are marked by integer numbers starting with 1. The cell name is the concatenation of the column and the row numbers. For example, BC23 is the name for the cell that is in column 55, row 23.
Sometimes another numeration system is used: RXCY, where X and Y are integer numbers, showing the column and the row numbers respectfully. For instance, R23C55 is the cell from the previous example.
Your task is to write a program that reads the given sequence of cell coordinates and produce each item written according to the rules of another numeration system.

输入输出格式

输入格式:

The first line of the input contains integer number n n n ( 1<=n<=105 1<=n<=10^{5} 1<=n<=105 ), the number of coordinates in the test. Then there follow n n n lines, each of them contains coordinates. All the coordinates are correct, there are no cells with the column and/or the row numbers larger than 106 10^{6} 106 .

输出格式:

Write n n n lines, each line should contain a cell coordinates in the other numeration system.

输入输出样例

输入样例#1: 复制

2 
R23C55
BC23

输出样例#1: 复制

BC23 
R23C55

思路

题目给出了两种行列位置的表示方法,一个是Excel表示法,一个是(R,C)坐标表示法,我们要做的就是将输入的一种表示转换成另一种表示再输出。
可以通过26进制(字母)与10进制(数字)互相转换解决问题

#include<cmath>
#include<cctype>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#define re register int
using namespace std;
inline int read(){
int x=0,w=1;
char ch=getchar();
while(ch!='-'&&(ch<'0'||ch>'9')) ch=getchar();
if(ch=='-') w=-1,ch=getchar();
while(ch>='0'&&ch<='9') x=(x<<1)+(x<<3)+ch-48,ch=getchar();
return x*w;
}
const char *Const=" ABCDEFGHIJKLMNOPQRSTUVWXYZ";
char s[101]; inline void Solve1() {
int i=0,j=0,num1=0,num2=0;
int t[101];
for(++i;isdigit(s[i]);++i) num2=num2*10+s[i]-'0';
for(++i;s[i];++i) num1=num1*10+s[i]-'0';
for(;num1;num1=num1/26-!(num1%26)) {
if(num1%26) t[++j]=num1%26;
else t[++j]=26;
}
for(;j;--j) putchar(Const[t[j]]);
printf("%d\n",num2);
} inline void Solve2() {
int i=0,num1=0,num2=0;
for(;isupper(s[i]);++i) (num2*=26)+=s[i]-'A'+1;
for(;s[i];++i) (num1*=10)+=s[i]-'0';
printf("R%dC%d\n",num1,num2);
} int main() {
//freopen("1b.in","r",stdin);
//freopen("1b.out","w",stdout);
int n;
bool flag;
n=read();
for(re i=1;i<=n;++i) {
scanf("%s",s);
flag=0;
for(int i=0;s[i]&&!flag;++i) if(i&&isdigit(s[i-1])&&isupper(s[i])) flag=1; //若字母前出现数字,一定是(R,C)法
if(flag) Solve1();
else Solve2();
}
return 0;
}

最新文章

  1. xss利用和检测平台
  2. BSA基础数据维护
  3. [Effective C++ --018]让接口容易被正确使用,不易被误用
  4. ubuntu:configure error:cannot find ssl libraries
  5. JavaScript 的setAttribute兼容性解决
  6. Cortex-M3和Cortex-M4 Fault异常应用之二 ----- Fault处理函数的实现
  7. Oracle undo我们需要掌握什么
  8. java定时器schedule和scheduleAtFixedRate区别
  9. Data Block Compression
  10. 待解决问题 :JDBC indexInsert.addBatch(); 为什么不生效 PSTM
  11. jsp 标签文件
  12. mongodump and mongorestore
  13. R语言-散点图进阶
  14. HTML5 audio元素如何使用js与jquery控制其事件
  15. [LintCode] 395. Coins in a Line 2_Medium tag: Dynamic Programming, 博弈
  16. Gulp 项目简单构建,自动刷新页面
  17. Oracle10g客户端链接服务端配置
  18. Map按照数值进行排序
  19. JAVA EE 博客实例
  20. 剑指offer——面试题19:正则表达式匹配

热门文章

  1. Instagram 为什么不用redis
  2. React 代码共享最佳实践方式
  3. 老J的技术分享之总结
  4. 比物理线程都好用的C++20的协程,你会用吗?
  5. MindSpore模型验证
  6. Python正则表达式的七个使用范例
  7. [拒绝Visual Studio] 团队博客目录
  8. ES6中的Set和Map对象数据结构
  9. [Python] 地图API
  10. [bug] IDEA Maven 项目 Module 不加粗,无法编译