Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task. 

Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as
many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly. 

Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the
numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie's valet. The last line of the input contains five zeros and no output should be generated for it.

Output

For each situation, your program should output one line containing the string "Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.", where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as
many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output "Charlie cannot buy coffee.".

Sample Input

12 5 3 1 2
16 0 0 0 1
0 0 0 0 0

Sample Output

Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.

Charlie cannot buy coffee.

这题可以用多重背包,用dp[m][5]分别记录m价钱刚好能买到的物品个数的最大值,买1元,5元,10元,25元物品的个数。

#include<stdio.h>
#include<string.h>
#define inf 88888888
int max(int a,int b){
return a>b?a:b;
}
int w[10]={0,1,5,10,25},v[10]={1,1,1,1,1,1};
int dp[10006][6];
int main()
{
int n,m,i,j,a,b,c,d,k,ans,sum;
int num[19];
while(scanf("%d%d%d%d%d",&m,&num[1],&num[2],&num[3],&num[4])!=EOF)
{
if(m+num[1]+num[2]+num[3]+num[4]==0)break;
if(m>num[1]+num[2]*5+num[3]*10+num[4]*25){
printf("Charlie cannot buy coffee.\n");continue;
}
if(num[1]>=m){
printf("Throw in %d cents, 0 nickels, 0 dimes, and 0 quarters.\n",m);continue;
}
for(i=0;i<=m;i++){
dp[i][0]=-inf;
}
dp[0][0]=dp[0][1]=dp[0][2]=dp[0][3]=dp[0][4]=0; for(i=1;i<=4;i++){
ans=num[i]*w[i];
if(ans>=m){
for(j=w[i];j<=m;j++){
if(dp[j-w[i]][0]>=0){
if(dp[j-w[i]][0]+v[i]>dp[j][0]){
dp[j][0]=dp[j-w[i]][0]+v[i];
dp[j][1]=dp[j-w[i]][1];dp[j][2]=dp[j-w[i]][2];dp[j][3]=dp[j-w[i]][3];dp[j][4]=dp[j-w[i]][4];
dp[j][i]++; }
}
}
}
else{
k=1;sum=0;
while(sum+k<num[i]){
sum+=k;
for(j=m;j>=k*w[i];j--){
if(dp[j-k*w[i]][0]>=0){
if(dp[j-k*w[i]][0]+k*v[i]>dp[j][0]){
dp[j][0]=dp[j-k*w[i]][0]+k*v[i];
dp[j][1]=dp[j-k*w[i]][1];dp[j][2]=dp[j-k*w[i]][2];dp[j][3]=dp[j-k*w[i]][3];dp[j][4]=dp[j-k*w[i]][4];
dp[j][i]+=k; }
} }
k=k*2;
}
k=num[i]-sum;
for(j=m;j>=k*w[i];j--){
if(dp[j-k*w[i]][0]>=0){
if(dp[j-k*w[i]][0]+k*v[i]>dp[j][0]){
dp[j][0]=dp[j-k*w[i]][0]+k*v[i];
dp[j][1]=dp[j-k*w[i]][1];dp[j][2]=dp[j-k*w[i]][2];dp[j][3]=dp[j-k*w[i]][3];dp[j][4]=dp[j-k*w[i]][4];
dp[j][i]+=k; }
} }
}
}
if(dp[m][0]>0)
printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",dp[m][1],dp[m][2],dp[m][3],dp[m][4]);
else printf("Charlie cannot buy coffee.\n");
//printf("%d\n",dp[m][0]);
}
return 0;
}

最新文章

  1. Xamarin的不归路-生成安卓错误3
  2. .NET实现微博粉丝服务平台接口
  3. 初始化Git的配置
  4. [ucgui] 对话框8——Framewin小工具
  5. RocEDU.阅读.写作《图解TCP/IP》
  6. u-boot启动流程分析(1)_平台相关部分
  7. window8.1中用户的管理员权限的提升方法
  8. 开源Jabber(XMPP) IM服务器介绍
  9. EasyUI 树形菜单tree 定义图标
  10. CSS鼠标样式
  11. OC本学习笔记Foundatio框架集
  12. Express安装入门与模版引擎ejs
  13. 使用Jax-rs 开发RESTfull API 入门
  14. [ZOJ3435]Ideal Puzzle Bobble
  15. 开源软件:NoSql数据库 - 图数据库 Cassandra
  16. EChart.js 笔记一
  17. SPI设计
  18. POI 导出
  19. centos7 hive + 远程mysql 搭建笔记
  20. 插件PageHelper实现分页查询

热门文章

  1. 编译安装 nginx -1.14.2
  2. Head First 设计模式 —— 14. 复合 (Compound) 模式
  3. Mac配置jmeter环境变量
  4. Can&#39;t locate Time/HiRes.pm in @INC (@INC contains
  5. 【Linux】centos 7中,开机不执行rc.lcoal中的命令
  6. 攻防世界 - Web(二)
  7. 如何查看U盘的VID和PID
  8. Java基础复习3
  9. Azure Terraform(六)Common Module
  10. CTO也糊涂的常用术语:功能模块、业务架构、用户需求、文档……