Beauty of Array

Time Limit: 2 Seconds Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

题意

给定一串数字,求所有连续的子序列的和,如果一个数字出现多次,则只计算一次

Solve

去统计每个数字被加的次数即可,注意数据范围

对于一个连续的序列来说,如果有重复的数字,那么后面的数字就可以忽视掉。所以对于一个数字xxx,只需要去计算以这个xxx为结尾和开头的序列,两者相乘即为该数字被加的次数

Code

/*************************************************************************

	 > Author: WZY
> School: HPU
> Created Time: 2019-04-09 17:07:29 ************************************************************************/
#include <bits/stdc++.h>
#define ll long long
#define ull unsigned long long
#define ms(a,b) memset(a,b,sizeof(a))
const int inf=(1<<30);
const ll INF=(1LL*1<<60);
const int maxn=1e6+10;
const int mod=1e9+7;
const int maxm=1e3+10;
using namespace std;
int vis[maxn];
int main(int argc, char const *argv[])
{
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
freopen("out.txt", "w", stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
int t;
cin>>t;
int n,x;
ll ans;
while(t--)
{
ms(vis,0);
ans=0;
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>x;
ans+=1LL*x*((i-vis[x])*(n-i+1));
vis[x]=i;
}
cout<<ans<<endl;
}
return 0;
}

最新文章

  1. 常见UI布局之1-2-1单列变宽布局
  2. pwnable echo1
  3. Laravel系列2入门使用
  4. Js分页插件,支持页面跳转
  5. Win7 远程 Ubuntu 桌面 mate desktop,并实现中文输入法
  6. poj-----(2828)Buy Tickets(线段树单点更新)
  7. UVALive - 6577 Binary Tree 递推+找规律
  8. hdu 4666 最大曼哈顿距离
  9. [LeetCode]题解(python):023-Merge k Sorted Lists
  10. Mac 下office 2013制作组合表
  11. LeetCode 665. Non-decreasing Array (不递减数组)
  12. shell拼写检查,利用Linux字典
  13. arcgis for js 根据多边形自动缩放
  14. paramiko__摘抄
  15. sbt 学习
  16. Luogu P2048 [NOI2010]超级钢琴
  17. Maven介绍及安装与配置
  18. DOM元素查找
  19. ORACLE-016:ora-01720 授权选项对于&#39;xxxx&#39;不存在
  20. byobu copy

热门文章

  1. c#页面查询、数据显示
  2. 同步阻塞IO模型
  3. 大数据学习day25------spark08-----1. 读取数据库的形式创建DataFrame 2. Parquet格式的数据源 3. Orc格式的数据源 4.spark_sql整合hive 5.在IDEA中编写spark程序(用来操作hive) 6. SQL风格和DSL风格以及RDD的形式计算连续登陆三天的用户
  4. 关于vue-cli中-webkit-flex-direction: column失效问题
  5. CentOS7 搭建maven私服Nexus
  6. Oracle LOB类型
  7. Lombok安装及Spring Boot集成Lombok
  8. 一文详解 OpenGL ES 纹理颜色混合
  9. 使用 WPF 做个 PowerPoint 系列 基于 OpenXML 解析实现 PPT 文本描边效果
  10. CF1141C Polycarp Restores Permutation 题解