https://pintia.cn/problem-sets/994805342720868352/problems/994805390896644096

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

代码:
#include <bits/stdc++.h>
using namespace std; char s[111][300], out[1111];
int len[111]; int main() {
int N;
scanf("%d", &N);
getchar();
for(int i = 1; i <= N; i ++) {
cin.getline(s[i], 300);
} int minn = 333;
for(int i = 1; i <= N; i ++) {
len[i] = strlen(s[i]); for(int j = 0; j <= len[i] / 2 - 1; j ++)
swap(s[i][len[i] - j - 1], s[i][j]); if(len[i] < minn) {
minn = len[i];
continue;
}
} int cnt = -1;
for(int j = 0; j < minn; j ++) {
int flag = 1;
for(int i = 1; i <= N; i ++) {
if(s[i][j] != s[1][j]) flag = 0;
}
if(flag == 0) break;
cnt = j;
} if(cnt != -1) {
for(int i = cnt;i >= 0; i --) {
printf("%c", s[1][i]);
}
printf("\n");
}
else
printf("nai\n"); return 0;
}

  

最新文章

  1. C/C++的基本数据类型
  2. Steve Loughran:Why not raid 0,its about time and snowflakes!!!
  3. 用Charles抓取https接口数据
  4. CF 371B Fox Dividing Cheese[数论]
  5. Codeforces 721D [贪心]
  6. Android Studio如何添加override
  7. 004-谈一谈lock和synchronized
  8. h5的video标签
  9. window下nginx的常用命令
  10. web监控,if 语句
  11. spring 开发 Tars
  12. perventDefault, stopPropagation, stopImmediatePropagation 三者的区别
  13. 【Java并发编程】之十六:深入Java内存模型——happen-before规则及其对DCL的分析(含代码)
  14. 虚拟机中liunx安装教程
  15. 【xsy1116】数学题 奥数题
  16. springMVC 访问静态资源
  17. Oracle游标解析
  18. swipe.js 使用方法
  19. ASP.NET MVC学习目录
  20. javaweb(三十一)——国际化(i18n)

热门文章

  1. hello,Python
  2. python 3下对stm32串口数据做解析
  3. Xilinx与modelsim的仿真联调
  4. poj 2349 Arctic Network(prime)
  5. Asp.Net实现在线人数统计 (转)
  6. 20155203 实验一《Java开发环境的熟悉》实验报告
  7. 20155211 2016-2017-2 《Java程序设计》第十周学习总结
  8. LVS入门篇(四)之LVS实战
  9. Training: MySQL I (MySQL, Exploit, Training)
  10. Drupal views 学习之初识