After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
​5
​​ ), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:
For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

题意:第一行输出参加考试的学校数。再按分数、人数、学校名的字典序进行排序。

思路:首先需要构造一个学校结构体,读取输入之后进行分数的计算。然后对结构体实现一个排序。注意需要求得每个学校的总分后在进行取整,不然有一个3分的测试用例过不去。

题解:

 #include<cstdlib>
 #include<cstdio>
 #include<vector>
 #include<map>
 #include<algorithm>
 #include<iostream>
 #include<string>
 using namespace std;
 struct institution {
     int rank;
     string name;
     float score;
     int num;
 };
 string lowCase(string str) {
     ; i < str.length(); i++) {
         if (str[i] >= 'A' && str[i] <= 'Z') {
             str[i] = str[i] - 'A' + 'a';
         }
     }
     return str;
 }
 bool cmp(institution a, institution b) {
     if (a.score != b.score) return a.score > b.score;
     else if (a.num != b.num) return a.num < b.num;
     else return a.name < b.name;
 }
 //这里不能直接返回score的取整部分,
 //题目的意思是要算出totalscore之后,
 //再进行取整,否则有一个3分的用例过不去。
 float trueScore(string id, float score) {
     ];
     if (c == 'A') return score;
     else if (c == 'B') return score / 1.5f;
     else return score * 1.5f;
 }
 int main() {
     int n;
     map<string, institution> mapp;
     scanf("%d", &n);
     string id, school;
     float score;
     ; i < n; i++) {
         cin >> id;
         cin >> score;
         cin >> school;
         school = lowCase(school);
         score = trueScore(id, score);
         if (mapp.find(school) != mapp.end()) {
             mapp[school].num++;
             mapp[school].score += score;
         }
         else {
             institution ins;
             ins.name = school;
             ins.num = ;
             ins.score = score;
             mapp[school] = ins;
         }
     }

     vector<institution> result;
     for (map<string, institution>::iterator it = mapp.begin(); it != mapp.end(); it++) {
         //对分数进行取整
         it->second.score = (int)it->second.score;
         result.push_back(it->second);
     }

     sort(result.begin(), result.end(), cmp);
     printf("%d\n", result.size());
     ;
     score = result[].score;
     ; i < result.size(); i++) {
         if (result[i].score != score) {
             rank = i + ;
             score = result[i].score;
         }
         cout << rank << " " << result[i].name << " " << (int)result[i].score << " " << result[i].num << endl;
     }
     ;
 }

最新文章

  1. 【OS】实模式和保护模式区别及寻址方式
  2. [版本管理]有惊无险修复svn服务器Invalid filesystem revision number问题
  3. Ext.util.TaskRunner定时执行任务
  4. loj 1271
  5. BZOJ4154: [Ipsc2015]Generating Synergy
  6. 如何设置div的宽度为100%-xx px?
  7. php 防止sql注入
  8. Go循环引用问题
  9. Android开发系列之SQLite
  10. PythonCrawl自学日志(2)
  11. Access restriction:The type JPEGCodec is not accessible due to restriction on required library C:\Program Files\Java\jre6\lib\rt.jar
  12. HDU ACM 4578 Transformation-&amp;gt;段树-间隔的变化
  13. 判断0-N之间出现1的次数
  14. Oracle学习笔记之存储过程
  15. 主席树[可持久化线段树](hdu 2665 Kth number、SP 10628 Count on a tree、ZOJ 2112 Dynamic Rankings、codeforces 813E Army Creation、codeforces960F:Pathwalks )
  16. Java 装饰模式
  17. linux操作文件和文件夹
  18. Vasya And The Mushrooms CodeForces - 1016C (前缀和模拟)
  19. Redis字符串操作
  20. 解决mybatis报错Result Maps collection does not contain value for java.lang.Integer

热门文章

  1. 51NOD 1353:树——题解
  2. C++中友元简介
  3. 20135331 文艺 java实验
  4. HDOJ(HDU).1864 最大报销额 (贪心)
  5. bzoj1024: [SCOI2009]生日快乐(DFS)
  6. 添加网站标题logo
  7. 【套题】qbxt国庆刷题班D2
  8. [ssh]ssh系列之一
  9. spring中使用@Async注解进行异步处理
  10. Codeforces 351B Jeff and Furik 概率 | DP