Problem 2221 RunningMan

Accept: 17    Submit: 52
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

 Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).

 Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)

 Sample Input

2
100 100
200 100

 Sample Output

No
Yes

 Hint

In the second example, the RunningMan team can arrange 60, 60, 80 people for the three rounds. No matter how the opposite team arrange their 100 people, they cannot win.

 Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

 
题目大意:给你两个数,代表R,O两组的总人数n,m,现在玩三轮游戏,三局两胜,如果R组派出的人数大于等于本轮O组派出的人数,那么R组获胜,否则O组获胜,问你是否存在一种安排,不论O组怎么派队,R组都胜利。存在即输出Yes,否则输出No。
 
解题思路:现在将R组分为3队,人数为x,y,z。那么如果满足题意,则R组中每两个队伍都必须获胜,另外一队必输。
需同时满足: x+y >= m-1    表示:x,y两队胜,z队输。z队队员0个人跟O组除了跟x,y对战的另一队人数为1人对战,失败。
       x+z >= m-1
       y+z >= m-1 且 x+y+z = n
联立方程组,解得 n >= 3*(m-1)/2
 
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main(){
int T,n,m;
scanf("%d",&T);
while(T--){
scanf("%d%d",&n,&m);
if(n >= 1.5*(m-1)){
puts("Yes");
}else{
puts("No");
}
}
return 0;
}

  

 
 

最新文章

  1. centos 7 安装音乐播放器(亲测可用)(转载)
  2. jquery weibo 留言
  3. java中String的一些方法
  4. topcoder SRM 625 DIV2 IncrementingSequence
  5. Memcached 笔记与总结(7)增加虚拟节点
  6. MYSQL例题合集
  7. Spring源码下载地址
  8. Redis 和 Memcached 的区别详解
  9. 【Oracle】RAC添加新节点
  10. Android 开发 AirPlay Server
  11. Effective C++笔记05:实现
  12. calc()
  13. webapi 自定义缓存实现
  14. Docker attach
  15. HDU 6103 17多校6 Kirinriki(双指针维护)
  16. centos7-vmware克隆后的配置
  17. mysql数据库配置优化(占cpu过高问题)
  18. 使用 urllib 进行身份验证
  19. WebGL学习笔记二
  20. Netty简单使用

热门文章

  1. 为openstack服务使能debug模式
  2. 关于小程序bindregionchange事件在IOS崩溃的问题
  3. innerText、innerHTML
  4. IO相关2(文件输入输出)
  5. 【spring源码】spring web 启动与关闭
  6. Python3之shutil模块
  7. linux 下PATH环境变量
  8. 多气体组分DEM流动的DMP并行内存错误
  9. [转] python提取计算结果的最大最小值及其坐标
  10. [原创]在Centos7上搭建私有的Gitlab服务器