CRB and Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 558    Accepted Submission(s): 227

Problem Description
CRB is now playing Jigsaw Puzzle.
There are N kinds of pieces with infinite supply.
He can assemble one piece to the right side of the previously assembled one.
For each kind of pieces, only restricted kinds can be assembled with.
How many different patterns he can assemble with at most M pieces? (Two patterns P and Q are considered different if their lengths are different or there exists an integer j such that j-th piece of P is different from corresponding piece of Q.)
 
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains two integers N, M denoting the number of kinds of pieces and the maximum number of moves.
Then N lines follow. i-th line is described as following format.
k a1 a2 ... ak
Here k is the number of kinds which can be assembled to the right of the i-th kind. Next k integers represent each of them.
1 ≤ T ≤ 20
1 ≤ N ≤ 50
1 ≤ M ≤ 105
0 ≤ k ≤ N
1 ≤ a1 < a2 < … < ak ≤ N

 
Output
For each test case, output a single integer - number of different patterns modulo 2015.
 
Sample Input
1
3 2
1 2
1 3
0
 
Sample Output
6

Hint

possible patterns are ∅, 1, 2, 3, 1→2, 2→3

 
 
题目大意:给你t组测试数据,每组给n和m分别表示有n种商品,让你排列出最长长度为m的序列,有n行,每行有k表示该种商品后边可以放k种商品,然后后边是k个数。
 
解题思路:这道题跟嫦娥那题其实比较像,都是先用dp求出转移方程,然后套用一下矩阵快速幂加速。因为是要求最长长度为m的序列,所以就需要求出长度为0 -> m的所有结果。分奇偶。当为偶:a1+a2+a3+a4....a2K 那么(a1+a2+a3....ak)*(1+ak)   。当为奇:a1+a2+a3+a4....a2K+1 那么(a1+a2+a3....ak)*(1+ak+1)+ak+1。    这就可以用dfs去处理。
 
#include<bits/stdc++.h>
using namespace std;
typedef long long INT;
const int MOD=2015;
int n;
struct Matrix{
int a[52][52];
Matrix(){
memset(a,0,sizeof(a));
}
void clr(){
memset(a,0,sizeof(a));
}
void init(){
for(int i=1;i<=n;i++){
a[i][i]=1;
}
}
Matrix operator *(const Matrix & X)const{
Matrix ret;
int i,j,k;
for(int i=1;i<=n;i++){ //可以先枚举k。再用n*n去取模,能加速。
for(int j=1;j<=n;j++){
for(int k=1;k<=n;k++){
ret.a[i][j] = ret.a[i][j] +a[i][k]*X.a[k][j];
}
ret.a[i][j]%=MOD;
}
}
return ret;
}
Matrix operator +(const Matrix & X)const {
Matrix ret;
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
ret.a[i][j]=a[i][j]+X.a[i][j];
}
}
return ret;
}
};
Matrix one;
Matrix Pow(Matrix A,int x){
Matrix ret;
ret.init();
while(x){ //可以换成for加速
if(x&1)
ret=ret*A;
A=A*A;
x>>=1;
}
return ret;
}
Matrix dfs(Matrix a,int k){
if(k==1)
return a;
if(k%2){
return (dfs(a,k/2)*(Pow(a,k/2+1)+one))+Pow(a,k/2+1);
}else{
return dfs(a,k/2)*(Pow(a,k/2)+one);
}
}
int main(){
int t,m,k,a;
scanf("%d",&t);
while(t--){
Matrix trans;
trans.clr();
scanf("%d%d",&n,&m);
one.init();
for(int i=1;i<=n;++i){
scanf("%d",&k);
for(int j=1;j<=k;++j){
scanf("%d",&a);
trans.a[i][a]=1;
}
}
if(m==1){
printf("%d\n",n+1);
continue;
}
Matrix ans=dfs(trans,m-1);
INT sum=0;
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
sum+=ans.a[i][j];
}
}
sum+=n+1;
printf("%lld\n",sum%2015);
}
return 0;
}

  

 
 

最新文章

  1. Linux x64 下 Matlab R2013a 300 kb 脚本文件调试的 CPU 占用过高问题的解决办法
  2. Mac:文件夹树型展示 tree
  3. Xamarin.ios——First APP
  4. sql优化建议
  5. 每天一个Linux命令---tcpdump
  6. Codeforces Round #248 (Div. 2) A. Kitahara Haruki&#39;s Gift
  7. 逆向最大匹配分词算法C#
  8. Smart210学习记录-------linux驱动中断
  9. LeetCode-Data Stream as Disjoint Intervals
  10. IOS系统中使用zepto的live事件绑定不了的一个办法
  11. strstr和memcmp函数的实现
  12. C#根据函数名称执行对应的函数
  13. getActionBar()空指针异常
  14. angular路由为空重定向到指定路由
  15. keycode简记表
  16. vs2013配置opencv2.4.13
  17. Java如何将每个单词的第一个字符转为大写?
  18. 关于 EF 对象的创建问题
  19. discuz 文件模板edit
  20. [LeetCode&amp;Python] Problem 557. Reverse Words in a String III

热门文章

  1. 动态绑数据(Repeater控件HeaderTemplate和ItemTemplate)
  2. 割点(Tarjan算法)【转载】
  3. nginx添加缓存以及判断是否缓存生效
  4. hdu1845(a^b的因子和%p)
  5. linux文件系统相关资料
  6. 4、OpenCV Python 像素运算
  7. BFS【bzoj1667】: [Usaco2006 Oct]Cows on Skates滑旱冰的奶牛
  8. Scene is unreachable due to lack of entry points and does not have an identifier for runtime access via -instantiateViewControllerWithIdentifier解决办法
  9. CF959D Mahmoud and Ehab and another array construction task 数学
  10. json几种读取方式,ArrayList循环读取【转】