Palindrome

Time Limit: 15000MS Memory Limit: 65536K

Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, “Can you propose an efficient algorithm to find the length of the largest palindrome in a string?”

A string is said to be a palindrome if it reads the same both forwards and backwards, for example “madam” is a palindrome while “acm” is not.

The students recognized that this is a classical problem but couldn’t come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said “Okay, I’ve a better algorithm” and before he starts to explain his idea he stopped for a moment and then said “Well, I’ve an even better algorithm!”.

If you think you know Andy’s final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string “END” (quotes for clarity).

Output

For each test case in the input print the test case number and the length of the largest palindrome.

Sample Input

abcbabcbabcba

abacacbaaaab

END

Sample Output

Case 1: 13

Case 2: 6


解题心得:

  1. 就是叫你去求一个字符串中的最长回文串,暴力肯定是会超时的,可以去看看manacher算法,这个算法不是很难。manacher详解。这就是一个manacher算法的模板题,看懂了就会做了。

#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1e6+100;
char s[maxn<<1],ch[maxn<<1];
int rl[maxn<<1];
int get_ch(int len)
{
int ch_len = 0;
for(int i=0; i<len; i++)
{
ch[ch_len++] = '#';
ch[ch_len++] = s[i];
}
ch[ch_len++] = '#';//注意要把最后一个#给加上去
return ch_len;
} int manacher(int ch_len)
{
int max_right = 0,pos = 0,Max = 0;;
for(int i=0;i<ch_len;i++)
{
rl[i] = 1;
if(i < max_right)
rl[i] = min(rl[(pos<<1)-i],max_right-i);
while(i+rl[i]<ch_len && i-rl[i]>=0 && ch[i+rl[i]] == ch[i-rl[i]])
rl[i]++;
//max_right、pos更新
if(i + rl[i]-1 > max_right)
{
max_right = i+rl[i]-1;
pos = i;
}
//记录最大的那一个回文串
if(rl[i] > Max)
Max = rl[i];
}
return Max-1;//记得要减去1
} int main()
{
int t = 1;
while(scanf("%s",s) != EOF)
{
if(s[0] == 'E' && s[1] == 'N' && s[2] == 'D' && strlen(s) == 3)
break;
int len = strlen(s);
int len_ch = get_ch(len);//将元字符串改写
int ans = manacher(len_ch);
printf("Case %d: %d\n",t++,ans);
}
return 0;
}

最新文章

  1. SQL Server数据库性能优化之SQL语句篇【转】
  2. 新人学习Android开发遇到的小问题总结
  3. 2.Android 自定义通用的Item布局
  4. 66.为什么有时候在ISE软件中,顶层文件不能置顶?
  5. DB2行转列、列转行等操作
  6. 静态资源库CDN服务
  7. 对TMemoryStream的一些改进(用到了LockFile)
  8. Linux命令之文本处理(二)
  9. console.dir()和console.log()的区别
  10. 如何开发webpack plugin
  11. 用C#开发的一个通用的地铁换乘查询工具
  12. Python【每日一问】09
  13. dd 命令常用功能收集(ing...)
  14. 彻底抛弃脚本录制,LR脚本之使用web_custom_request函数自定义http请求
  15. windows emacs 中拷贝文件
  16. Linux vi编辑器使用技巧
  17. win+ R下的常见命令
  18. PHP基础知识(二)
  19. ios PNG Crush error (PNG图片错误)
  20. 如何优雅地使用win10的Linux子系统

热门文章

  1. Solr创建索引问题
  2. 基于 opencv图像去噪
  3. setTimeout() 实现程序每隔一段时间自动执行
  4. EF批量插入数据耗时对比
  5. Android 网络提交数据(使用Asynchronous Http Client)
  6. AJPFX关于JDK,JRE,JVM的区别与联系
  7. html学习笔记-DOM
  8. Intellij idea 创建JAVA项目
  9. web标准、可用性、可访问性
  10. Python中的绝对路径和相对路径