POJ1426——Find The Multiple

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

代码:

#include<iostream>
#include<bits/stdc++.h>
#include<queue>
using namespace std; void BFS(int x){
queue<int> q ;
q.push(1);
int y;
while (!q.empty())
{
y=q.front();
q.pop();
for (int i = 0; i < 2; i++)
{
if (i==0) q.push(y*10);
else
q.push(y*10+1);
if (y%x==0)
{
cout<<y<<endl;
return ;
} }
}
} int main(){
int x;
while ((cin>>x)&&x)
{
BFS(x);
}
}

最新文章

  1. Eclipse相关设置
  2. Ubuntu 16.04 LTS更新
  3. QAQ
  4. vector、string实现大数加法乘法
  5. Java多线程练习
  6. 定位vc运行时库问题 依赖问题,屡试不爽的一招
  7. hibernate 一对多 多对一 关系表 增删改查大礼包ps二级查也有
  8. html&lt;!DOCTYPE&gt;声明标签
  9. .NET Core微服务之基于Steeltoe使用Spring Cloud Config统一管理配置
  10. ASP.NET Core WebApi使用Swagger生成api
  11. virtualenv之python虚拟环境
  12. unity代码添加动画,并传参数
  13. mongoDB使用小记
  14. Oracle Spatial GIS相关研究
  15. python list中append()与extend()用法
  16. .Net Core 使用swagger UI
  17. 从零开始Vue项目实战(四)-路由
  18. virtualenv下使用matplotlib
  19. ABAP开发常见任务
  20. 最短路径之迪杰斯特拉算法(Java)

热门文章

  1. 老杜告诉你java小白到大神是怎么炼成的(转载)
  2. MySQL索引篇之索引存储模型
  3. 生成树-RSTP基础配置
  4. NOIP 模拟 $28\; \rm 割海成路之日$
  5. Docker小白到实战之容器数据卷,整理的明明白白
  6. Seata–分布式事务
  7. spring boot 的JPA项目
  8. 【maven】私服搭建
  9. QT 中的QTableWidget
  10. rabbitMq镜像集群