A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1,a2,···,an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:

(a1,a2,···,an) → (|a1 − a2|,|a2 − a3|,···,|ana1|)

  Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

(8,11,2,7) → (3,9,5,1) → (6,4,4,2) → (2,0,2,4) → (2,2,2,2) → (0,0,0,0).

The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:

(4,2,0,2,0) → (2,2,2,2,4) → (0,0,0,2,2) → (0,0,2,0,2) → (0,2,2,2,2) → (2,0,0,0,2) →

(2,0,0,2,0) → (2,0,2,2,2) → (2,2,0,0,0) → (0,2,0,0,2) → (2,2,0,2,2) → (0,2,2,0,0) →

(2,0,2,0,0) → (2,2,2,0,2) → (0,0,2,2,0) → (0,2,0,2,0) → (2,2,2,2,0) → (0,0,0,2,2) → ···

  Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

Input

  Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.

Output

  Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.

Sample Input

4
4
8 11 2 7
5
4 2 0 2 0
7
0 0 0 0 0 0 0
6
1 2 3 1 2 3

Sample Output

ZERO
LOOP
ZERO
LOOP

HINT

 采用思路时使用两个数才存储,其中一个用于计算,另一个用于判断结束,也就是排序找出最大值,如果过最大值为0那就不是循环。另外还要计算判断次数。耗时370ms。

Accepted

#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std; int main()
{
int m, n,t,i;
cin >> m;
while (m--) {
cin >> i;
n = i;
vector<int>arr,arr2;
while (i--)
{
cin >> t;
arr.push_back(t);
arr2.push_back(t);
}
for (i = 1;;i++)
{
t = arr[0]; for (int j = 0;j < n - 1;j++)
arr[j]= arr2[j] = abs(arr[j] - arr[j + 1]);
arr[n - 1] = arr2[n - 1] = abs(arr[n - 1] - t);
if (i > 1000) {
cout << "LOOP" << endl;
break;
} sort(arr2.begin(), arr2.end());
if (!arr2[arr2.size() - 1])break;
}
if (i <= 1000)cout << "ZERO" << endl;
}
}

最新文章

  1. 标准产品+定制开发:专注打造企业OA、智慧政务云平台——山东森普软件,交付率最高的技术型软件公司
  2. Cloud Design Patterns Book Reading(undone)
  3. 如何选中一个Checkbox,设置无效?
  4. LeetCode Rectangle Area (技巧)
  5. 《Entity Framework 6 Recipes》中文翻译——第九章EntityFramework在N层架构程序中的应用(七)
  6. Oracle约束操作
  7. Latex笔记-基本布局
  8. java_eclipse_maven_svn_主题彩色插件_全屏插件
  9. 服务管理--systemctl命令
  10. Extjs学习笔记之九 数据模型(上)-extjs
  11. Maven常用命令:
  12. Vue.js 生态之vue-router
  13. Mac office ppt无法正常输入文字的问题解决方案
  14. VS调试DLL代码使用”附加到进程“
  15. LeetCode--155--最小栈
  16. cmd无法输入中文解决方案
  17. NETSDK1061错误解决
  18. Ionic Tabs
  19. re 模块 常规方法使用
  20. LaTeX 使用:itemize,enumerate,description 用法

热门文章

  1. banner自用图床
  2. FTPClient类的API
  3. JAVA基础(二)—— 常用的类与方法
  4. docker 上传到docker hub 采坑
  5. c++指针数组与二维数组的最大区别
  6. POJ-3660(Floyd算法)
  7. linux进程隐藏手段及对抗方法
  8. 01-Spring概述(总览)
  9. 修改RedHat7的root用户密码
  10. Linux目录,rpm及top,vi命令简记