【九度OJ】题目1433:FatMouse 解题报告

标签(空格分隔): 九度OJ


http://ac.jobdu.com/problem.php?pid=1433

题目描述:

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

输入:

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

输出:

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入:

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

样例输出:

13.333
31.500

Ways

开始贪心算法的题。

这个题目的意思是,M的cat foode去每个room里换JavaBean,每个房间都是按等比例换。

可以证明,只有把rate=JavaBean/catFoode值最大的先换了,才会使最终换的的javaBean最多。

也就是相当于换性价比最高的东西,这样就会总获得量最大。

这就需要排序,我在做这个题的时候遇到一个问题,是自己考虑的不周到。刚开始没有把每个房间当做一个整体,这样在rate排序之后,rate和房间对应不上。把room作为整体就能解决了。

第二个问题还是没有把answer在每个循环中清零。

#include <stdio.h>
#include <algorithm> using namespace std; struct room {
float cat;
float bean;
float rate;
} rooms[1000]; bool cmp(room a, room b) {
return a.rate > b.rate;
} int main() {
int m;
int n;
float answer;
while (scanf("%d", &m) != EOF && m != -1) {
answer = 0.0;
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%f%f", &rooms[i].cat, &rooms[i].bean);
rooms[i].rate = rooms[i].cat / rooms[i].bean;
}
sort(rooms, rooms + n, cmp);
for (int i = 0; i < n ; i++) {
if (m > rooms[i].bean) {
answer += rooms[i].cat;
m -= rooms[i].bean;
} else {
answer += (((float) m) / rooms[i].bean) * rooms[i].cat;
break;
}
}
printf("%.3f\n", answer);
}
return 0;
}

Date

2017 年 2 月 28 日

最新文章

  1. QQServer_update
  2. Fiddler的基本介绍
  3. asp.net 的脚本
  4. vim中选择匹配文本删除技巧
  5. 转:postgresql:pg_restore: [archiver] input file does not appear to be a valid archive的解决方法
  6. 【转】android中TextAppearanceSpan的使用
  7. 移动app安全测试
  8. 201521123095 《Java程序设计》第7周学习总结
  9. STM32F10XX存储器细节
  10. 关于ruby -gem无法切换淘宝源
  11. C#之FTP上传下载(二)
  12. 【一天一道LeetCode】#77. Combinations
  13. Collections模块下的Counter
  14. workqueue --最清晰的讲解
  15. python爬虫实践教学
  16. kafka0.8--0.11各个版本特性预览介绍
  17. FICO(费埃哲)评分系统有什么优缺点?在国内的发展怎么样?
  18. JAVA语言编程思维入门
  19. 什么是Meta标签? 哪些Meta标签对搜索引擎SEO优化有作用?
  20. Mysql千万级大表优化策略

热门文章

  1. 【6】蛋白质组学鉴定定量软件之MaxQuant
  2. Nginx 编译 echo 模块
  3. python-django-自定义查询Q函数和F函数
  4. python—模拟生成双色球号和大乐透号
  5. mysql端口查看与修改-netstat命令使用
  6. rsync实现windows和windows之间的数据同步
  7. Django结合Echarts在前端展示数据
  8. Identity Server 4 从入门到落地(五)—— 使用Ajax访问Web Api
  9. javaSE基础知识(走向编程的门口)— 更新完毕
  10. 使用clion阅读eos源码