E - Speed Limit(2.1.1)

Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can record their speed and the total time they have driven. Unfortunately, their
record keeping strategy is a little odd, so they need help computing the total distance driven. You are to write a program to do this computation. 



For example, if their log shows

Speed in miles perhour Total elapsed time in hours
20 2
30 6
10 7

this means they drove 2 hours at 20 miles per hour, then 6-2=4 hours at 30 miles per hour, then 7-6=1 hour at 10 miles per hour. The distance driven is then (2)(20) + (4)(30) + (1)(10) = 40 + 120 + 10 = 170 miles. Note that the total elapsed time is always
since the beginning of the trip, not since the previous entry in their log.

Input

The input consists of one or more data sets. Each set starts with a line containing an integer n, 1 <= n <= 10, followed by n pairs of values, one pair per line. The first value in a pair, s, is the speed in miles per hour and the second value, t, is the total
elapsed time. Both s and t are integers, 1 <= s <= 90 and 1 <= t <= 12. The values for t are always in strictly increasing order. A value of -1 for n signals the end of the input. 

Output

For each input set, print the distance driven, followed by a space, followed by the word "miles"

Sample Input

3
20 2
30 6
10 7
2
60 1
30 5
4
15 1
25 2
30 3
10 5
-1

Sample Output

170 miles
180 miles
90 miles
#include<iostream>
using namespace std;
int main( )
{
int n;
int a,b,s,k;
while(cin>>n&&n>0)
{
s=0,k=0;
while(n--)
{
cin>>a>>b;
s=s+a*(b-k);
k=b; }
cout<<s<<" miles"<<endl;
}
return 0;
}


最新文章

  1. python httprequest, locust
  2. android最常用的退出方法
  3. css计数器详解
  4. Maven 项目导入错误解决。
  5. artTemplate模板引擎的源码拜读
  6. linux ----Inode的结构图
  7. vim技巧和坑
  8. javax.el.PropertyNotFoundException错误
  9. 通过百度获取IP地址对应的经纬度
  10. 【LeetCode练习题】Next Permutation
  11. Postman参数化使用以及中文乱码问题解决
  12. 前端之HTML内容
  13. Django-1-URL路由系统
  14. cocos-lua3.17 Lua tablrView工具类
  15. BZOJ4739 : 定向越野
  16. tensorFlow(二)线性回归
  17. 搭建React项目(一):在网页中使用
  18. February 1st, 2018 Week 5th Thursday
  19. CentOS系统实现SSH无密码登录的方法
  20. git解决 remote: Permission to wuheng1991/site-manager.git denied to XXX

热门文章

  1. 重写PHP的explode办法
  2. HDU 4883 Best Coder Round 2 TIANKENG’s restaurant 解读
  3. 记View跨界平局
  4. [TWRP 2.8.4 ] 小米 3W 中文-英文版本 twrp
  5. Ubuntu 13.04/12.10安装Oracle 11gR2图文教程(转)
  6. 采用truelicense进行Java规划license控制 扩展可以验证后,license 开始结束日期,验证绑定一个给定的mac住址
  7. 直接插入排序---java实现
  8. HDU-2857-Mirror and Light(计算几何)
  9. Duanxx的Design abroad: C++矩阵运算库Eigen 概要
  10. hdu 4454 Stealing a Cake(三分之二)