Knight Moves

option=com_onlinejudge&Itemid=8&category=11&page=show_problem&problem=380" target="_blank" style="text-decoration:none">From:UVA,
439

Time Limit: 3000 MS


A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set ofn squares
on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing
the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

题目大意:

给你起点和终点。依照象棋里面的象走日的走法,要走几步。

解题思路:

这代题目调试了几个小时。原来是错在节点坐标没初始化。所以做题还是要小心啊。

代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<queue> using namespace std; struct node{
int i,j,step;
node(int i0=0,int j0=0,int step0=0){i=i0,j=j0,step=step0;}
}mymap[10][10]; int dirX[8]={ 1,-1,-1, 1,2, 2,-2,-2};//
int dirY[8]={-2,-2, 2, 2,-1,1,-1,1},i1,j1,i2,j2;
char c1,c2; bool judge(int di,int dj){
if(di>=0&&di<8&&dj>=0&&dj<8) return true;
return false;
} bool read(){
if(cin>>c1>>j1>>c2>>j2){
i1=c1-'a',i2=c2-'a',j1--,j2--;
return true;
}
return false;
} void initial(){
for(int i=0;i<8;i++){
for(int j=0;j<8;j++){
mymap[i][j].step=-1;
mymap[i][j].i=i;//哎。
mymap[i][j].j=j;//之前死在这。
}
}
} void bfs(){
queue <node> path;
bool ans =false;
mymap[i1][j1].step=0;
path.push(mymap[i1][j1]);
while(!path.empty()&&!ans){
node s=path.front();
path.pop();
for(int k=0;k<8;k++){
int di=s.i+dirY[k],dj=s.j+dirX[k];
if(judge(di,dj)&&mymap[di][dj].step==-1){
mymap[di][dj].step=s.step+1;
path.push(mymap[di][dj]);
}
if(di==i2&&dj==j2) {ans=true;break;}
}
}
} void outResult(){
printf("To get from %c%d to %c%d takes %d knight moves.\n",c1,j1+1,c2,j2+1,mymap[i2][j2].step);
} int main(){
while(read()){
initial();
bfs();
outResult();
}
return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。

最新文章

  1. SQL Server群集如何在线检测
  2. Python默认版本修改
  3. Dirac Delta Function
  4. 解析XML文件的几种常见操作方法—DOM/SAX/DOM4j
  5. 嵌入式Linux应用开发——Linux下的C编程基础
  6. MongoDB 客户端 MongoVue
  7. (转载)Android理解:显式和隐式Intent
  8. 【JavaScript】字符串处理函数集合
  9. sqlserver2012 评估期已过问题处理
  10. Hbase常见异常
  11. jqGrid一些操作
  12. linux修改句柄数
  13. 设置PATH和CLASSPATH
  14. formData的实现
  15. django模板引擎自定义变量
  16. asp.net core2.0学习笔记
  17. House Robber III
  18. idea的svn安装
  19. Spring Data Redis —— 快速入门
  20. React-Native 之 ScrollView介绍和使用

热门文章

  1. SOLOWHEEL - 电动独轮车 - SOLOWHEEL俱乐部聚会活动火热报名中
  2. openjpa框架入门_Demo概览(一)
  3. PPPOE 模拟环境搭建
  4. OPEN-E安装中注意的问题
  5. 基于Redis Sentinel的Redis集群(主从Sharding)高可用方案(转)
  6. Eclipse设置的断点失效的解决办法
  7. 用xml建立仓库的逻辑层的操作
  8. 浅析ArrayList,LinkedList的执行效率
  9. hdu1507--二分图最大匹配
  10. 怎样使用jlink一键烧录整个flash Hi3518 a c e Hi3515 Hi3512