Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 15345    Accepted Submission(s): 7234

Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 
Input
The first line of input contains an integer T, denoting the number of test cases.

For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)

Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 
Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 
Sample Input
2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1
 
Sample Output
Case 1: 1
Case 2: 2
 代码:

//网络流:福特-富尔克森算法(二维数组版本)
#include<iostream>
#include<string>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1e3+5;
int v;
int capacity[maxn][maxn],flow[maxn][maxn];
//capacity保存u到v的容量,flow保存u到v的流量,反方向时为负
//函数计算返回总流量
int networkflow(int source, int sink) {
memset(flow,0,sizeof(flow));
int totalflow=0;
while(true) {
//BFS寻找增广路径
vector<int> parent(maxn,-1);
queue<int> q;
parent[source]=source;
q.push(source);
while(!q.empty()) {
int here=q.front();q.pop();
for(int there=0;there<v;++there)
//沿着还有剩余容量的边搜索
if(capacity[here][there]-flow[here][there]>0&&parent[there]==-1) {
q.push(there);
parent[there]=here;
}
}
//没有增广路经存在
if(parent[sink]==-1) break;
int amount=INF;
for(int p=sink;p!=source;p=parent[p]) {
amount=min(capacity[parent[p]][p]-flow[parent[p]][p],amount);
}
//决定通过增广路径传输流
for(int p=sink;p!=source;p=parent[p]) {
flow[parent[p]][p]+=amount;
flow[p][parent[p]]-=amount;
}
totalflow+=amount;
}
return totalflow;
}
int main() {
int t,cnt=1;
scanf("%d",&t);
while(t--) {
int n,m;
scanf("%d%d",&n,&m);
v=n;
memset(capacity,0,sizeof(capacity));
for(int i=0;i<m;++i) {
int x,y,c;
scanf("%d%d%d",&x,&y,&c);
capacity[x-1][y-1]+=c;
}
printf("Case %d: %d\n",cnt++,networkflow(0,n-1));
}
return 0;
}

最新文章

  1. Blender 之 Splash 代码分析
  2. eclipse里打开SWT项目找不到source/design的图形UI设计界面
  3. Python开发【前端】:CSS
  4. C#高级编程笔记 Day 1, 2016年8月 30日 名词定义
  5. Cocos2dx 学习笔记整理----在项目中使用图片(二)
  6. Vulkan Tutorial 11 Shader modules
  7. C/C++生成随机数
  8. 责任链模式 职责链模式 Chain of Responsibility Pattern 行为型 设计模式(十七)
  9. Windows反复重启的可能的解决办法
  10. java笔记 -- java简单结构代码解析及注释
  11. iOS的动态代理模式的实现
  12. tf中的run()与eval()【转载】
  13. jQuery的ajaxFileUpload上传插件——刷新一次才能再次调用触发change
  14. GitHub使用笔记2:github常用操作
  15. C/C++基础----string, vector, array
  16. 浅析网站建设的PHP,JAVA语言分析
  17. win环境下使用sqlmap写shell + MYSQL提权(默认就是system权限)
  18. 使用CSS3建立不可选的的文字
  19. 160426、JavaScript 秘密花园
  20. 查看环境变量CLASSPATH, PATH ,JAVA_HOME--------&gt;mac

热门文章

  1. js 获取多少天前
  2. Java web学习 Cookie&amp;&amp;Session
  3. Idea报错Check $M2_HOME environment variable and mvn script match.
  4. RestServer 2.0 正式版发布
  5. Setup and Configure the vsftpd server in CentOS 7 operation system
  6. Mybatis动态查询语句
  7. Android 开发笔记___图像按钮__imageButton
  8. HTML5与phonegap接口对比
  9. C#实现DirectShow技术开发准备
  10. 比特币区块结构Merkle树及简单支付验证分析