题目链接:http://poj.org/problem?

id=3335

Description

This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewhere in the hall such that a spectator sitting anywhere
on the boundary of the hall can view the scoreboard (i.e., his line of sight is not blocked by a wall). Note that if the line of sight of a spectator is tangent to the polygon boundary (either in a vertex or in an edge), he can still view the scoreboard. You
may view spectator's seats as points along the boundary of the simple polygon, and consider the scoreboard as a point as well. Your program is given the corners of the hall (the vertices of the polygon), and must check if there is a location for the scoreboard
(a point inside the polygon) such that the scoreboard can be viewed from any point on the edges of the polygon.

Input

The first number in the input line, T is the number of test cases. Each test case is specified on a single line of input in the form n x1 y1 x2 y2 ... xn yn where n (3
≤ n ≤ 100) is the number of vertices in the polygon, and the pair of integers xi yi sequence specify the vertices of the polygon sorted in order.

Output

The output contains T lines, each corresponding to an input test case in that order. The output line contains either YES or NO depending on whether the scoreboard can be placed inside the hall conforming to the problem conditions.

Sample Input

2
4 0 0 0 1 1 1 1 0
8 0 0 0 2 1 2 1 1 2 1 2 2 3 2 3 0

Sample Output

YES
NO

Source

PS:

顺时针给出点!

求是否有核!

逆时针给出仅仅要反一下输入就好了:http://blog.csdn.net/u012860063/article/details/41145157

代码例如以下:

#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;
#define eps 1e-8
const int MAXN=10017;
int n;
double r;
int cCnt,curCnt;//此时cCnt为终于分割得到的多边形的顶点数、暂存顶点个数
struct point
{
double x,y;
};
point points[MAXN],p[MAXN],q[MAXN];//读入的多边形的顶点(顺时针)、p为存放终于分割得到的多边形顶点的数组、暂存核的顶点 void getline(point x,point y,double &a,double &b,double &c) //两点x、y确定一条直线a、b、c为其系数
{
a = y.y - x.y;
b = x.x - y.x;
c = y.x * x.y - x.x * y.y;
}
void initial()
{
for(int i = 1; i <= n; i++)p[i] = points[i];
p[n+1] = p[1];
p[0] = p[n];
cCnt = n;//cCnt为终于分割得到的多边形的顶点数。将其初始化为多边形的顶点的个数
}
point intersect(point x,point y,double a,double b,double c) //求x、y形成的直线与已知直线a、b、c、的交点
{
double u = fabs(a * x.x + b * x.y + c);
double v = fabs(a * y.x + b * y.y + c);
point pt;
pt.x=(x.x * v + y.x * u) / (u + v);
pt.y=(x.y * v + y.y * u) / (u + v);
return pt;
}
void cut(double a,double b ,double c)
{
curCnt = 0;
int i;
for(i = 1; i <= cCnt; ++i)
{
if(a*p[i].x + b*p[i].y + c >= 0)q[++curCnt] = p[i];// c因为精度问题,可能会偏小。所以有些点本应在右側而没在。
//故应该接着推断
else
{
if(a*p[i-1].x + b*p[i-1].y + c > 0) //假设p[i-1]在直线的右側的话。
{
//则将p[i],p[i-1]形成的直线与已知直线的交点作为核的一个顶点(这种话,因为精度的问题,核的面积可能会有所降低)
q[++curCnt] = intersect(p[i],p[i-1],a,b,c);
}
if(a*p[i+1].x + b*p[i+1].y + c > 0) //原理同上
{
q[++curCnt] = intersect(p[i],p[i+1],a,b,c);
}
}
}
for(i = 1; i <= curCnt; ++i)p[i] = q[i];//将q中暂存的核的顶点转移到p中
p[curCnt+1] = q[1];
p[0] = p[curCnt];
cCnt = curCnt;
}
void solve()
{
//注意:默认点是顺时针,假设题目不是顺时针,规整化方向
initial();
for(int i = 1; i <= n; ++i)
{
double a,b,c;
getline(points[i],points[i+1],a,b,c);
cut(a,b,c);
}
/*
假设要向内推进r。用该部分取代上个函数
for(int i = 1; i <= n; ++i){
Point ta, tb, tt;
tt.x = points[i+1].y - points[i].y;
tt.y = points[i].x - points[i+1].x;
double k = r / sqrt(tt.x * tt.x + tt.y * tt.y);
tt.x = tt.x * k;
tt.y = tt.y * k;
ta.x = points[i].x + tt.x;
ta.y = points[i].y + tt.y;
tb.x = points[i+1].x + tt.x;
tb.y = points[i+1].y + tt.y;
double a,b,c;
getline(ta,tb,a,b,c);
cut(a,b,c);
}*/
/* //多边形核的面积
double area = 0;
for(int i = 1; i <= curCnt; ++i)
area += p[i].x * p[i + 1].y - p[i + 1].x * p[i].y;
area = fabs(area / 2.0);
*/
}
/*void GuiZhengHua(){
//规整化方向。逆时针变顺时针。顺时针变逆时针
for(int i = 1; i < (n+1)/2; i ++)
swap(points[i], points[n-i]);
}*/
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i = 1; i <= n; i++)//逆时针反一下从n->1就好了
{
scanf("%lf%lf",&points[i].x,&points[i].y);
}
points[n+1] = points[1];
solve();
if(cCnt < 1)
printf("NO\n");//无核
else
printf("YES\n");//有核
}
return 0;
}

最新文章

  1. 读书笔记--SQL必知必会19--存储过程
  2. angularJs 控制文本长度,超出省略号过滤器
  3. Strong AI Versus Weak AI
  4. 虚拟化之lxc
  5. Centos 6.5 RedHat 6 安装mysql
  6. OAuth认证的过程
  7. VC6神迹外挂的DIY
  8. 分区工具fdisk,gdisk,parted
  9. BUAA-OO-第二单元总结
  10. 集成学习—boosting和bagging
  11. 「CTSC2018」暴力写挂
  12. Centos 06 文件类型和扩展名&amp;索引节点inode和存储块block
  13. MySQL查询性能优化(精)
  14. Phone 3rd Recovery
  15. mysql group by using filesort优化
  16. Spring Cloud Config(配置中心)
  17. docker 修改port 端口
  18. 在js或jquery中动态添加js脚本【转】
  19. pacbio bax.h5文件处理及ccs计算
  20. Linux - history命令的常用方法

热门文章

  1. Welcome-to-Swift-08枚举 (Enumerations)
  2. input最大长度限制问题
  3. 严格次小生成树[BJWC2010] (树链剖分,倍增,最小生成树)
  4. scrapy之Selectors
  5. freemarker实现自定义指令和自定义函数
  6. 【NOIP2015】子串(字符串DP)
  7. 10个JavaScript难点--摘抄
  8. Django ConnectionAbortedError WinError 10053 错误
  9. 将xml转换为PHP数组
  10. redis基本类型和操作