Color Me Less
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30146   Accepted: 14634

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target
set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255.
The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation


Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped.
The input is terminated by a line containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set.




If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input

0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1

Sample Output

(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)

Source

解题思路:

一种颜色用三元组(r,g,b)表示。两个颜色的距离为

给出16个已知的颜色值,求这里面距离给定的颜色值距离最短的颜色值。

枚举,比較距离就能够了。

代码:

#include <iostream>
#include <cmath>
const int inf=0x7fffffff;
using namespace std; struct RGB
{
double r,g,b;
int match;//用来记录距离最短的颜色是第几个
}rgb[100]; int main()
{
int k=1;
while(cin>>rgb[k].r>>rgb[k].g>>rgb[k].b&&rgb[k].r!=-1&&rgb[k].g!=-1&&rgb[k].b!=-1)
{
k++;
}
double dis;
for(int i=17;i<=k-1;i++)
{
dis=inf;
for(int j=16;j>=1;j--)
{
double temp=sqrt((rgb[i].r-rgb[j].r)*(rgb[i].r-rgb[j].r)+(rgb[i].g-rgb[j].g)*(rgb[i].g-rgb[j].g)+(rgb[i].b-rgb[j].b)*(rgb[i].b-rgb[j].b));
if(dis>=temp)
{
dis=temp;//最短距离
rgb[i].match=j;//第i中颜色距离第j种颜色距离最短
}
}
}
for(int i=17;i<=k-1;i++)
{
cout<<"("<<rgb[i].r<<","<<rgb[i].g<<","<<rgb[i].b<<") maps to ("<<rgb[rgb[i].match].r<<","<<rgb[rgb[i].match].g<<","<<rgb[rgb[i].match].b<<")"<<endl; }
return 0;
}

最新文章

  1. man手册中文版实现
  2. click 绑定(一)无参数的click 事件绑定
  3. hibernate逆向工程生成的实体映射需要修改
  4. SQL Server插入中文数据后出现乱码
  5. 数据恢复案例分享:MSSQL 2000 错误823
  6. Base64编码的原理
  7. spring-data-redis和jedis版本对应收集总结
  8. html5中JavaScript删除全部节点
  9. M2阶段团队个人贡献分
  10. CSS技巧-文字分散对齐的方法
  11. L275 Climate Change Is Having a Major Impact on Global Health
  12. python学习之高阶函数
  13. 微信为啥不能直接下载.apk安装包
  14. Postgres数据库获取所有的索引信息的SQL
  15. 生成学习算法(Generative Learning algorithms)
  16. [CoreOS 转载] CoreOS实践指南(一)
  17. OpenCL 存储器次序的验证
  18. Javac之glb与lub
  19. Oracle 关于WKT构造SDO_GEOMETRY的问题。
  20. macOS 安装 pcl 1.8.0

热门文章

  1. 遇到的兼容性bug
  2. WPF和WinForm的区别, 数据驱动与事件驱动的优势对比
  3. 文件/文件夹权限设置命令chmod的具体使用方法
  4. LightOJ 1070 Algebraic Problem (推导+矩阵高速幂)
  5. 停止复制代理后AWT缓存组的行为
  6. es69
  7. Tools--&gt;SQL Server Profiler监视数据库
  8. PHP 获取完整URL地址
  9. 【2017 Multi-University Training Contest - Team 2】 Is Derek lying?
  10. 查看oracle数据库的启动时间